[Tiled Map Importer] Unable to build Tiled map

Hello guys.
I am trying to use a Tiled map in my project, but have run into an issue preventing me from building.
I’ve been able to get the Tiled Map Importer/Processor referenced etc. But, when I add my map and attempt to build the game, I am presented with an exception being thrown: “Unable to read beyond the end of the stream”.

I have attempted re-loading and string to re-import the asset, but to no avail.

Monogame version:
Monogame Extended Tiled Version: 3.7.0
^— Content Pipeline version: 3.7.0

I would greatly appreciate any help or guidance you guys can give :slight_smile:

Hi @SilenceOfTheLambdas Welcome to the Forums…

Just want to say, nice username haha, I like what you did there!

Have you tried using MG3.7? unsure if extended is compatible already or not.

Happy Coding!

Thanks for replying; I downgraded to MG3.7, but it made no difference. Here is a screenshot of the error (might be more useful):

How big is the file in Windows?

it’s 892 bytes in size (according to file explorer)

Might be too small?

hmm, that seems like an odd issue. I’ll make a larger file and see how it works out.
Thanks again :wink:

1 Like

Welp, I made the file larger (it’s now 3Kb) but I’m still getting the same error. :frowning:

At least you ruled that out, for some reason, on the weekends, every dev forum dies, give it another day to get someone in here that knows the thing.

1 Like

Since this is an extension someone else made for monogame you might get better help by posting it as an issue here, https://github.com/craftworkgames/MonoGame.Extended/issues?

1 Like