TMX build issue.

Hey All.
I know this has been addressed previously, but I cannot find a solution to my problem. I’m very new to monogame. I have all of the latest packages installed and when I add a tilemap (.tmx file) the pipeline will simply not build that file. It will build .png’s just find and everything in between, but the darn .tmx files. There is no default importer and processor. I tried using the XML importer but with no luck. Any help is greatly appreciated.

Hi @Andrew,
I’m pretty sure Monogame does not support tmx maps by default. However, Monogame.Extended contains a content pipeline extension for tiled maps. So that might be a good place to start, I haven’t got a lot of experience with Monogame.Extended, so I can’t really comment on it. Try this page:

Thanks for the reply. I’ve previously read through this and tried to follow it, but I keep running into roadblocks that they dont discuss on there. Ill look through it again and see if I missed anything. I appreciate the help!

If you’re having issues with map rendering try this thread: Problems using Extended Tiled Map

But yeah, MonoGame.Extended’s documentation is bit of a work in progress at the moment it seems

Actually, there are quite a few topics on here surrounding MonoGame.Extended’s Tiled library, it might be worth your while to read around a bit, apparently some people have had better luck with the 1.1 release, I can’t really comment on that though as I do not use MonoGame.Extended myself. Another place to look is to go through the code on Github, that might help you understand it better:
Anyway, Good Luck with your project.

Hello @Andrew,

For time being if you are experiencing pipeline issues I suggest you read the following GitHub issue and the workarounds posted there by the community.

A maintenance “sprint” is scheduled for the month of June 2020. More details coming soon.

After reading this, I was able to get the processor and importer to populate by placing all of my references into my content folder. However, the tmx file was still not able to build.