Tons of issues, but getting it on the roll appears to be impossible

I really feel embarrassed that after after my more than 30 years of programming experience with several languages it has come to this, but perhaps i need to ask around.

Let’s say this, I’ve been looking for ages to get a gaming framework that fits my way of working. Messing around a bit in the monogame docs, I was interested with what I saw. Now I don’t remember installing it on my Mac (running Sierra), but I appeared to have mono and even the compilers for C# were there, so I started to experiment with the C# language. Everything I wrote in C# so far appears to work, or at least as far as it should, as I am still setting things up a little :slight_smile:

So I installed Visual Studio and some systems I programmed in other languages before did I put in, no problem, and I’m even beginning to like C#.

Now it comes, I tried to install MonoGame… There it went wrong.
I could get MonoGame in Visual Studio… I created each of the following templates with the start up wizard, and altered none of them, so all codes were untouched.

  • When I try build cross platform, it cannot find some stuff, which was meant to be in an x86 or a 64bit setup respectively, but that stuff appears missing (I was that one also noted elsewhere on the forum).
  • Well, I’m on Mac, so let’s try Mac App… Then I get the error about deployment for 10.6 being not possible requiring 10.7 in stead.
  • Okay, let’s now try the Windows App variant, and then it says it can’t find the “Microsoft.Xna” namespace as response to the ‘using’ commands on top of the basic .cs script. Now that one was odd, since that’s MonoGame’s basic namespace, isn’t it? But when I look around in my projects references I see the error mark next to the MonoGame reference, and when I take a look in the Reference Editor I see that MonoGame is not even listed at all.

Next (desperate) thing, cloned the MonoDevelop source, compiled, added MonoGame to it. All I could create was a library in MonoGame, well, better than nothing, I could link the .dll to VisualStudio, maybe… I push the compile button and hey… it says build succesful. That turned out to be a lie. A real lie. Nothing happened at all. How did find out? Easy, I added a line of which I knew it MUST create a parse error, as I was already doubting stuff was happening, and I was right, as even with forced parse errors (hey, deliberately removing a ; where it must be is a very easy way to force a parse error in most C variants) it says the build was successful. The .dll file that should be created or anything other kind of binary doesn’t exist anywhere in my file system, so I found out.

Of course, the only option I did not yet try is to open Virtual Box to try to install everything in Windows 7, as I think you can understand I am reluctant to run Windows in a VM on an already outdated Mac, especially when it comes to game creation, since those games need to be tested after all and with a VM on, I wonder how fast they’ll run XD.

Now, the idea did cross my mind that I made a total mess out of things and that an entirely clean approach would probably be best to deal with this, basically meaning removing mono, VS, MonoDevelop etc entirely and start fresh out, but I’m not yet sure if that is a good idea and if there are still other options open. And that is why I’m here, with you today. :wink:

My MacOS version is 10.12.6 (Sierra)
Mono returns this string when I ask for its version: Mono JIT compiler version (2018-02/4fe3280bba1 Fri Jul 20 08:25:42 EDT 2018)
Visual Studio For Mac Community - 7.6.3 (build 1)
MonoGame 3.6

Since MonoGame is a widely used framework I do feel pretty stupid that I can’t get it to work, and the reason I come here and not to the issue tracker is because I’m not sure if these are bugs in MonoGame or if there were just things that went wrong on my side which caused stuff to malfunction. This is just crazy, I tell ya… or it drives me crazy…
Well at least I found in C# a good language for my non-game programs (always look on the bright side of life), but still… XD

Which MonoGame template did you create initially (Ex. DesktopGL)? There’s been a lot of fixes since MonoGame 3.6; can you try a develop version and see if that helps?

DesktopGL is indeed what I tried for the Cross-Platform template. Now I have one .mpack file for MonoGame that I did try in MonoDevelop but not yet in VS, most of all as I am not sure if that would conflict with the add-on that has already been installed.
With develop version, do you mean to clone the github-repository and try to install the stuff in there to be installed in stead of the ready-to-go packages? (I’m asking as I’ve seen the develop version been defined differently in several programming communities).

Yeah, I essentially mean the build from the latest source code. Building from source works, and you can also install the latest dev version here.