TouchPanel.GetState stuck input

There seems to be a bug with TouchPanel class. I have a link to a sample that illustrates the problem.

So if you start tapping more than one finger, like 2,3 or 4 in a mix of simultaneous taps and cascading taps, then sooner or later (may take up to a min of trying to stress the class) TouchPanel will report the presence of 1 or more touches even though you are not touching the screen. This has made my multi-touch game lock almost every time I play it. I hope it gets fixed soon.

I haven’t ran your sample, but we did fix a bunch of issues with TouchPanel recently.
If you are using the nuget package, try compile the latest code from github instead and see if this still happens.

I ran into a whole series of issues trying to use a dll from github instead of NuGet. To begin with, I downloaded the monodevelop branch as a zip and ran protobuild, then opened the windows phone solution. I found that all the sharp dx references are not found/missing, so after reading this thread I downloaded this and placed it in the ThirdParty folder. Now the references aren’t missing anymore but I cant build to any CPU, only ARM or x86 works, however I use both for device and emulator, but I also dont know how to add both and make the compiler choose one over the other depending on the deploy target. So for now I just built for ARM and went back to my test project. My test project was started as a MonoGame template and had 2 MonoGame NuGet references. Once I uninstalled the NuGet references, I discovered that this also deleted my GamePage.xaml too… so I re-added it from another project, but now the ‘_game = XamlGame.Create(“”, XnaSurface);’ line in GamePage.xaml reports that XnaSurface is not a PhonePageApplication which is strange because it works with NuGet MonoGame, so I replace ‘XnaSurface’ parameter with ‘this’ and no more bugs, but now when I deploy to device I get this exception:

System.IO.FileNotFoundException was unhandled by user code
  Message=Could not load file or assembly ‘SharpDX, Version=, Culture=neutral, PublicKeyToken=null’ or one of its dependencies. The system cannot find the file specified.
  FileName=SharpDX, Version=, Culture=neutral, PublicKeyToken=null
       at MonoGame.Framework.WindowsPhone.XamlGame`1.Create(String launchParameters, PhoneApplicationPage page)
       at GameName16.GamePage…ctor()

Not a pleasant experience at all… cant the MonoGame team just update the NuGet package?

It will get updated when the next version gets released.

All you should need to do is set the cpu and VS should find the references by itself.

Well I finally figured out how to make use for the latest github mono-develop dll and the bug still occurs. You can try it yourself with the sample I provided, remove the NuGet packages and add a reference to the latest dll. I hope this bug gets fixed soon.

It might be related to this bug:

You could try the work around I’ve suggested in the last comment.

You could try the work around I’ve suggested in the last comment.

Do you mean this?

try compile the latest code from github instead and see if this still happens.

I did that and I still get the error.
And am not sure it is the bug you have referenced in the link. It doesnt raise an exception and it does not involve gestures, only touch collection. The sample is really tiny and easy to checkout.

Here is a version of your example set up to build with monogame from git:
Grab that, extract it somewhere.

Grab monogame:
Extract this to MonoGame/ next to the InputBugSample folder.
Run protobuild.exe from in that folder.

Now open up GameName16.sln and run it on your device.

I’m doing this and the bug does not occur. I am testing on a Nokia 520.

I am testing on a 520 too, and did exactly as you said, and I still got the problem. When you launch the app, tap all 4 finger at the same time fast and repeatedly, mix in a few fast cascades, and in no time you will see white boxes stack up and remain there even if you don’t touch anymore. Afterwards, if you press the windows home button and back into the app, the inputs disappear but the app no longer registers any new input.

I can’t reproduce.
Nokia 520
OS: 8.0.10517.150

Here is an amazing view of me tapping my phone:

LOL I appreciate your effort. I noticed that your OS version was higher than mine (8.0.10328.78), so I updated my phone and the problem no longer appears, not even in the NuGet version of MonoGame.

(filler characters)