Trying to run game on fresh installed windows 7 64 (virtual machine)

I have no problem running my game on my laptop, which has no development tools installed, XNA or monogame or whatever installed.

Now, I tried copying it on a VM, which runs windows 7 64 bits, and it gives me this error, which I printed in the screen like this.

    using (Game1 game = new Game1())

catch (Exception e)

At first, It gave me the error that I didn’t have .net 4 installed, so I went and installed that, since that’s an important windows update anyway. Since I still had the same error, I also installed DirectX11, even though I am not sure if that’s required, although who doesn’t have DirectX11 installed in their system anyways.

So apart from .net 4 and DirectX11, what else does Monogame requires ? I suppose it has to be a windows update of some sort, because my laptop run my game with no errors, and there is literally nothing installed onto it other than basic windows updates.

Edit: this just hit me, could it possible be related to drivers not installed on VM ? or that’s not how it works ?

You need DirectX 9:

I installed what you linked me, I got the exact same error. This is the link I folloed to install DirectX and I ended up with DirectX 11, not DIrectX 9. Isn’t this supposed to be backwards compatible anyway?

Also,if I run dxdiag, I still see DirectX version: 11, following the link you gave me.

The VM will virtualise the graphics card too so unless the VM can pass through to the hardware then it’s unlikely to work.

Any idea how to make it work then ?

You have to go Devices > Install Guest Additions CD Image to install the VM driver(for 3d support you’ll need to boot windows 7 into safe mode), and also under vm settings you should probably add virtual memory.

1 Like

You haven’t said which VM you’re using but cra0zy has given you the virtualbox method.

Very few VMs support 3D hardware acceleration. For this reason we don’t explicitly support running a MonoGame application inside a VM.

Hmm, I see how it is. I just wanted to test if my game runs, since I don’t have a fresh installed win7 system to test my game right now.

I am running MonoGame without a problem in VirtualBox(Win7).

1 Like

oh I had to boot in safe mode, as you said, this is why I couldn’t install it. I didn’t see that in your answer. My bad. Thanks a lot !