Tweening NuGet Package problems

I really want to use Monogame.extended and massively appreciate all of the work that has gone into it. But every time I use it I feel like I’m an idiot.

I’m trying to get tweening working and found some documentation here:

Fantastic, this looks straight-forward. Let me get the NuGet packages for it and see how I get on.

Hmmmm, there appears to be no Tweener class in the library. Odd. It says the NuGet package was built 3 months - checking the code on github shows it was there in the source 3 months ago.

I’ve ended up building the Tweener Library from source - and that at least gives me the Tweener class but when I call the Update() method it requires me to install netstandard v2.0.0. And all attempts to install this via NuGet or manually break everything else :frowning:

Any help to make me feel less dumb appreciated :slight_smile:

Ah ha!

So more reading means that I now know:

  • that NuGet Packages are frozen at V1.1 from 23rd May 2018
  • I’ve downloaded this source and the Tweening library was completely different in V1.1.
  • confusingly the tutorial I was following was based on the new version and was published on 7th May 2018
  • Monogame.extended is currently being upgraded to NetStandard 2.0.0 and I should expect pain!

So I either need to find a old tutorial and try the old Tweening library or maybe I can take the current code but ‘reverse’ the upgrade to NetStandard.

Versioning fun! Would still appreciate any suggestions :slight_smile:

Everything you’ve discovered is basically correct. We’re in the middle of a major upgrade including moving to .NET Standard.

The thing that surprises me a bit is that you’re needing to ‘reverse’ the .NET Standard stuff. As far as I was aware, .NET Standard is compatible with .NET Framework so you shouldn’t need to reverse anything.

What version of Visual Studio (or other IDE) are you using? What version .NET Framework are you targeting? Chances are if you’re using the right versions everything will become a whole lot easier.

You might also want to checkout how the demos are setup. Once you start using .NET Core / .NET Standard and the new csproj format you’ll likely never want to go back. It’s much better imho.

Hello :slight_smile:

I’m using Visual Studio 2017 and targeting .NET Framework 4.5.

I think you’re probably right that I need to go forward with everything rather than backwards. I’ve already got some NuGet Monogame.Extended packages from V1.1 installed. I suspect it’s probably best to compile from source myself and put those in. The demos compile so I should be able to get it working.

It’s just one of those things where you want to have a quick play with something and you end up down the rabbit hole :slight_smile:

Will update my post once I’ve had a chance to ‘go forward’.

P.S. thanks for the huge amounts of work you’ve put into ME. I’m sure once I can get the basics up and running I’ll be a convert!

Checkout the compatibility table. You’ll need to be targeting at least 4.6.1 to use a .NET Standard 2.0 library.

Btw… once you’ve got the MonoGame.Extended source code on your machine you can build your own NuGet packages. Just run the build.ps1 powershell script and you should be good to go.

Fantastic! Thanks :slight_smile: That looks like it’s sorted it.

I’m new to the .NET Standard stuff. I was just looking for a way to target ‘.NET Standard 2.0’ in my project as it doesn’t come up in the list - although is the target for ME. Switching to 4.6.1 solves the problem :smile:

Thanks for the building NuGet package tip too.

Off to have a play with Tweening now! Cheers

1 Like


I’m feeling as dumb with these NuGet package, was quite excited to try Tweening too.

So, packages from repository seems to be still frozen, I’m targeting the 4.7 framework and downoading’em does not give me any tweening success.

I thus tried to build from the .ps1 to make my own packages but I encountered the following error " GitVersion: Process returned an error (exit code 1)."

I don’t really get where does this come from. Does the embedded git version from the tools need an update ?

Thanks in advance for any help concerning this issue.

PS: thanks for all the work put in the Monogame project :slight_smile:

I don’t know what that means?

I’ve never seen this error before. The only thing I can think of is that you might not be running the script from a git repository (in other words, did you download the source as a zip file maybe?)

You shouldn’t need to manually update anything in the tools. Cake is designed to automatically download the appropriate tools when you run the build.ps1 file. This happens on our build server for every commit and as far as I can tell it’s working just fine.

I think you might need to provide more detail on what exactly you’ve tried?

Hey ! Thanks for your quick presence !

It was a quick reference to XNA saying months ago, I should have given more context ^^

To provide you more detail:

  1. I downloaded the repository from ME Git
  2. Extracted the zip file
  3. Right clicked on build.ps1 to execute with powershell
  4. Got the GitVersion: Process returned an error (exit code 1)

So, I think you answered my question, I should run the script from a git repository. I’ll try it this evening

Cheers !

Yes, I suspect that is probably the reason.

GitVersion is a tool that uses the commits in the git repository to automatically generate a version number.

1 Like

All clear now, running v3.6.0-alpha0955 :smiley:

Thanks for your time, that was kind of a new-to-git question

Let’s roll !