Unable to build known working game after updates

I have been working on a game for a little over a year now using the MonoGame Mac Application template.
I originally created the project in Xamarin with Monogame 3.5 installed.
Eventually, I upgraded to Visual Studio for Mac, and still everything was working swimmingly.
A few weeks ago, I installed some updates when VS prompted, and since then, I have been unable to get the solution to build.
I have installed multiple different Monogame versions and even fully uninstalled Xamarin, Visual Studio, and any references to MonoGame that I could find.
I made no changes to the project between when it worked and when it didn’t

When building the project, I get the following two errors:

Error: linker command failed with exit code 1 (use -v to see invocation)
Error MM5109: Native linking failed with error code 1. Check build log for details. (MM5109)

I’m at the point where I’m trying to manually move classes to a fresh project, a MonoGame Cross Platform Desktop Application this time.
But I’m unable to run even the empty template.

It builds fine, but the Application Output shows:
Cannot open assembly ‘./test.Desktop.exe’: No such file or directory.

I’ve been googling for about 3 weeks now and have tried everything I can find.
Any suggestions would be more than welcome.
I’m starting to go bald from pulling my hair out

Just closing the loop on this.

After creating a new MonoGame Cross-Platform Desktop Application, I encountered the issue described here:

Once I added the missing line to the .csproj, I was able to build and run the empty template.
Then it was just a matter of moving assets from the old project to the new one.