Unable to install monogame 3.5

I wanted to set up Monogame 3.5 with Monodevelop 5.10 (on Ubuntu 16.04) as a requirement for a game development course, but I’ve hit multiple roadblocks. I hate to have someone hold my hand through a process, but this whole thing has taken me way too long to try and get right, so I need help.

Here is what I’ve done:

  • installed monodevelop using the software center
  • downloaded monogame 3.5 from the site, and ran these lines:
    sudo chmod +x monogame-sdk.run (to make it runnable)
    sudo ./monogame-sdk.run

This made monogame appear as “installed” as an add-in in monodevelop, and I was then able to open new projects, but there were no templates that appeared, which was something my class required. I tried uninstalling monogame, but I don’t remember what command I used. If I try to reinstall monogame 3.5, I get the lines:

Please uninstall any previous versions of MonoGame SDK

so I ran:


in terminal, but the command was not found…

I’ve been trying to get around this for hours, but to no avail.

Id just manually tear out all the mg related files and try to then install 3.6.
Some file probably got left and is causing a linking conflict.

Yank any files or templates left from mg out of mono-develop as well.

If all else fails uninstall monodevelop and reinstall it ackk but seriously whatever works. Linux also has the windows equivillent of scandisk which you could run overnight that would uncrosslink any files if there really was something really messed up deep down but its probably something stupid simple.

Do not follow the above comment, you won’t solve anything that way.

Try using the develop version of MonoGame for LInux, it should auto uninstall previous versions, than if you want the stable version you can run monogame-uninstall to uninstall the develop version and run the stable installer again.

Well crazy would know better then i would, i haven’t used linux for a long time.

Im sure its change a lot since i built it on linux, back then there wasn’t even a installer and the steps i went thru could fill a entire post.

I downloaded and ran the development version of monogame. I didn’t want to proceed past a “confirmation-to-continue” line in the terminal because it listed some dependencies (some optional). Here is the list:

Verifying archive integrity… All good.
Uncompressing Monogame Pipeline Installer…

  • mono-runtime…[Found]
  • gtk-sharp3…[Not Found]

Optional Dependencies:

  • MonoDevelop 6…[Not Found]
  • Rider…[Not Found]
  • referenceassemblies-pcl / mono-pcl…[Found]
  • ttf-mscorefonts-installer / mscore-fonts…[Not Found]

I assume that my missing “gtk-sharp3” is the underlying problem, so I searched for the package and got here, then clicked on version 2.99.3-2 (The Yakkety Yak). I’m not sure of where to go from here. I’m not sure if I need the other packages (Mono 6, Rider, ttf), but it says optional, so…

I found out I could just install gtk-sharp3 via terminal (face-palm), so I did that. Then I proceeded to install the developer version of monogame.

After typing “y” for yes, this is what I get:
Previous version detected, trying to uninstall... Could not uninstall, please uninstall any previous version of MonoGame SDK manually.

I should mention that I tried installing Monogame 3.4, which might be causing the “Previous version detected” issue, although it installed Monogame Pipeline.


I didn’t know how to uninstall my broken Monogame correctly, so I reinstalled Ubuntu (lol). From there, I went to the monogame documentation and directly followed the instructions. I installed all the stated dependencies and then installed monogame (developer version), making sure to remember any instructions for uninstallation.

I ran
sudo apt update
and opened monodevelop, and monogame is yet to be installed as an add-in…

Since I remembered the uninstall command to be
I successfully uninstalled the dev version of monogame so I could try the regular ol’ 3.5, and when I installed that, it kind of worked.

I actually got this error message of missing files:

WARNING: [MonoDevelop.AspNet,5.10] Could not load some add-in assemblies:
Could not find file “/usr/lib/monodevelop/AddIns/AspNet/System.Web.Helpers.dll”.
ERROR: Errors found in add-in '/usr/lib/monodevelop/AddIns/AspNet/MonoDevelop.AspNet.dll:
ERROR: The file ‘/usr/lib/monodevelop/AddIns/AspNet/System.Web.Helpers.dll’ referenced in the manifest could not be found.
ERROR: The file ‘/usr/lib/monodevelop/AddIns/AspNet/System.Web.Mvc.dll’ referenced in the manifest could not be found.
ERROR: The file ‘/usr/lib/monodevelop/AddIns/AspNet/System.Web.Razor.dll’ referenced in the manifest could not be found.
ERROR: The file ‘/usr/lib/monodevelop/AddIns/AspNet/System.Web.WebPages.Deployment.dll’ referenced in the manifest could not be found.
ERROR: The file ‘/usr/lib/monodevelop/AddIns/AspNet/System.Web.WebPages.dll’ referenced in the manifest could not be found.
ERROR: The file ‘/usr/lib/monodevelop/AddIns/AspNet/System.Web.WebPages.Razor.dll’ referenced in the manifest could not be found.
WARNING: The add-in ‘MonoDevelop.Debugger.Soft.AspNet,5.10’ could not be updated because some of its dependencies are missing or not compatible:
missing: MonoDevelop.AspNet,5.10

I’m going to try to find these files in the MonoGame source on GitHub. I really need this to work.

I think I’ve been a little quick to jump to conclusions. I’ll describe my MonoGame configuration then I will explain how I overlooked.

I’ve installed successfully installed MonoGame 3.5 despite the above errors (I’m not sure if they’re too important, anyway). I was successful because I followed the instructions in the documentation for setting up MonoGame on Linux; I installed all of the dependencies before installing MonoGame.

I completely overlooked the text descriptions for the project templates. This entire time I’ve been searching for the templates respective to each individual platform (MonoGame Windows Project for Windows, etc.). I should have payed more attention to what was in the MonoGame 3.5 installation, which is a MonoGame Cross Platform Desktop Project (“for Windows, Mac, and Linux using OpenGL.”).

I cannot believe I got so worked up over this when the solution was right under my nose! :sweat_smile:
I can finally resume my programming work, although, @harry-cpp, I wonder where the Mobile Project Add-ins for MonoGame are. Anyways, thank you so much for your help!

Xamarin does not support Linux so MonoGame hides the templates for it (Xamarin.Android, Xamarin.iOS).