Vector Ball - International Re-Colored Edition!

Updated June 10 - Improved the worst back ground.
Updated June 9 - Based on player feed-back (better visibility).

So here’s my break-out clone… Of sorts.
My 3rd iteration, and how I got into XNA, then monogame. Been at it, on and off, for a few years I guess.
I wanted something sharp, nice to look at, but not distracting.
Pics and download below.

-Very precise collision detection/ball physics.
-Bricks of ANY shape, ANY color :slight_smile:
-Homemade sound and music.
-22 power-ups! All with unique icons, sounds, indicators, and animations…
-20 unique levels (seperated into 3 sets)
-Fully programmable dot-matrix display.
-Save and continue
-Nuke everything button! (Hit ENTER - no completion bonus)
-Drag and drop new levels

PIC 1) quad-cluster of the menus and high score board. NOTE: The information page explains every power-up.
The level selector (bottom right), lets you start from any unlocked set.

PIC 2) All sorts of levels, with all sorts of effects. Bricks can be any shape and size, and have any number of properties. They can be glass, stone, steel or normal. Indestructible, explosive, moving, spinning… Some take a few hits, and some TELL TIME! Each level introduces something new.

Lots of power-ups, and they all combine as appropriate. Above you see a “Multi Ball”, combined with a “Fire Ball”. Below you can see the “Force Field” power-up. The vertical laser-beams reflect balls.

Other power-ups are: Point drops, score multipliers, extra balls, paddle size +/-, ball size +/-, ball speed +/-, reverse paddle, LASERS, fire-balls, PLASMA UPGRADE for aforementioned, auto-pilot, split-ball, save-tape, and MAGNET.

Aim the ball by holding right mouse button, and moving the mouse. shoot with left button. Enjoy!

Don’t miss out on warp-gates, clouds, and spinning things…
Put your name where it belongs! -The HIGH SCORE board of this FREE game :slight_smile:

choose the correct aspect ratio, and highest supported resolution, and remember to activate fullscreen!!!
DOWNLOAD INSTALLER (63 MEGS, International Edition)

Impressive :), good job !

Do you know Vector Ball was the name of a Mastertronic, I think, soccer type game release on Amstrad and others computers ? (two players looks like robots on a wireframe terrain)

Thanks, hehe, nope! Didn’t know! I named mine vector ball, because I was learning about vectors and thought they were a huge upgrade from c#'s Point/location system I had worked with earlier…

The game crashes for me shortly after starting it up :frowning: I think it happens when I hover over one of the menu buttons. I get an ArgumentOutOfRangeException. Looks very impressive though!

hm… Thanks for that. I will look into that immediately. You extracted the rar first? And tried run as admin? Then If you could tell me the size of your installer folder, I can see if that matches up with expectations… Confirm that it has all its components.

Also, you got by the title, and heard intro music…?

@monopalle: sych exception is most likely to come from something like

myarray[index] = foo;

somewhere whereas index has been incremented above myarray.getlength(0) or something like this.

In my case: installer didn’t allow me to choose where I want to put the game (very bad!) and game failed to run, I got a mscorlib crash when launching it, either from the directory directory of after installing it.

bonus: there are some remaining PNG files (HUD/testhud2.png, some other in level_selector) in content for example I guess they have no business there.


I tried this, still didn’t work.



That would throw an IndexOutOfRange exception. The ArgumentOutOfRangeException is thrown when an argument is not valid for some function. It’s thrown in MonoGame by the way.

Thanks for your replies… I’m looking into it, but I have no other responses yet, so I don’t know if you have a unique problem…

you got 343 files in 28 folders…? (also found under properties)

Jup, that’s exactly right.

To narrow it down further, are you able to hover over menu items, or will simply that crash it?
If you can hover over, is it only when you click an item that it crashes…?

There’s no animation or anything when I hover over them (not sure if there is one). Nothing happens when I click a menu item, and it doesn’t always immediately crash when I hover over it, but when it crashes it’s when my mouse is hovering over one of the buttons.

wow, that sounds terrible!

The buttons are supposed to light up individually when you hover over them, and play a sound…

You have OpenAL, and the newest monogame, and normal up to date .net…?
-Just in case my installer missed these…

…I have a special feeling its a sound issue. -Since that seems to coincide with the crash, and everything else works…

You don’t need to have MonoGame installed to run the game right (I do though)? .NET is up to date. Might be OpenAL, that sounds plausible. It doesn’t crash when I hover over the continue button, probably because it’s not clickable (no animation or sound either), but if that’s supposed to play a sound it might help you pinpoint the problem. Should the clickable buttons be lit up? They all look the same.

Thanks again. Yeah, continue is meant to be inactive at first… But the other buttons should light up, and play a sound, when you hover over the words (so not really the buttons, but the labels are sensitive).

Do you in fact hear sounds at all, besides the music…? If not, its gotta be a sound issue…

I will look at the installer now, see if it checks for OpenAL… It might be running fine on my machine, because I have it pre-installed, and maybe you don’t… We’ll see!

Nope, just the music.

Ok… I have a one minute fix for you, if you have the patience for this…
Thinking its a sound issue:
My code will only attempt to play sound, if the volume is set to more than zero.
To by-pass sound issues, we will set volume to zero.
Of coarse, you cant access the volume slider from the menus without triggering sounds.

FIX: Edit the value for volume in the games Settings.TXT file.

  1. To FIND the file, start the game, and while its running, and pull up task manager. From there, you can open the games install path with the click of a mouse…

  2. Once you are in the game folder, exit the running game app, and open the folder called “Files”, and open the Settings document…

  3. Beneath “master volume:” you will see a number, probably 0.7… set this to 0.0 and SAVE…
    -thats ‘zero period zero’ on your keyboard… #not_a_comma!

Relaunch game! And let this old man know how it goes…

I think I saw someone else have a similar issue with OpenAL and no speakers plugged in, or sound set to 0?

That works :slight_smile: Looks like it’s sound then.

yeah, there’s this thing where if you unplug the sound, windows goes to “no sound device” which screws with the game… But in this case, he did have music.

I’m thinking it is something with openAL too… But I dont know why my installer didnt catch that… I mean, isnt that the whole point of something like an installer?

thanks for the testing efforts! Glad to have it narrowed down some…

-That sound though, gonna have to get it to work :slightly_smiling:

while I’m working on it, you might simply want to get openAL, in case thats the issue…

Its a quick install, and if thats not the issue, you can uninstall like any app…

OpenAL Download HERE

I would like to ask though, have you played other monogame games recently that did have sound?