VideoPlayer GetTexture throwing E_INVALIDARG exception after updating to 3.6


After updating my UWP game from MonoGame 3.5 to 3.6, everything went well except for the VideoPlayer. I’m trying to play WMV files but the GetTexture API just throws the E_INVALIDARG exception from below. I can hear the sound of the video being played but can’t get the frames. Any idea what could be going wrong? Has any one else successfully tried this scenario?


“SharpDX.SharpDXException: HRESULT: [0x80070057], Module: [General], ApiCode: [E_INVALIDARG/Invalid Arguments], Message: The parameter is incorrect.\r\n\r\n at SharpDX.Result.CheckError()\r\n at SharpDX.MediaFoundation.MediaEngine.TransferVideoFrame(ComObject dstSurfRef, Nullable1 srcRef, RawRectangle dstRef, Nullable1 borderClrRef)\r\n at Microsoft.Xna.Framework.Media.VideoPlayer.PlatformGetTexture()\r\n at Microsoft.Xna.Framework.Media.VideoPlayer.GetTexture()\r\n at Flipper.Screens.CinematicScreen.Draw(GameTime gameTime)”

Has anyone solved this issue?

Same problem here with MonoGame 3.6.
Doing a UWP game and WMV video or mp4.

Running into this issue also, even on 3.7 got the same error…anyone has a solution ?

Hi. Finally i must convert my .MP4 to MP4 but mpg4 codec with movavi app. Some online converter too.