VS2022 Template only installing Android template

The title is pretty self-explanatory.

I just installed Visual Studio 2022 (.NET desktop, C++ Desktop, Unity, C++ Linux) and have tried to install the MonoGame templates from the Extensions menu. Everything worked until I tried to actually create a project and realized that it had only installed the Android template. I repeated the process and even tried reinstalling VS with no luck. Has anyone had this problem or knows how to deal with it? Thanks in advance - Logabe

Might be an issue that happened to me when I was trying to migrate from 3.8.0 to 3.8.1 in an Windows environment. After setting up the NET 6.0 and installing (and reinstalling) from the Extensions menu with no success I gave a try with this command on the PowerShell or CMD (same command from Getting Started: Setting up your development environment for Windows | MonoGame Documentation)

dotnet new --install MonoGame.Templates.CSharp

Perhaps you should give it a try. Iā€™m not sure if this is the same issue because I tested a bunch of other workarounds before using the dotnet command, too young to remember spontaneous workarounds :slight_smile:

1 Like

I was having the exact problem described, and this fixed it.