What can be done about "OpenAL drivers could not be found" on Android devices?

I am working on a game which is being tested (externally) on various Android devices. It works well on a lot of devices, but crashes on Samsung Galaxy S6. Fortunately I was given a callstack as follows:

Microsoft.Xna.Framework.Audio.NoAudioHardwareException: OpenAL drivers could not be found. ---> System.DllNotFoundException: openal32.dll
  at (wrapper managed-to-native) OpenTK.Audio.OpenAL.AL:GetError ()
  at Microsoft.Xna.Framework.Audio.OALSoundBuffer..ctor () [0x00000] in <filename unknown>:0 
  --- End of inner exception stack trace ---
at Microsoft.Xna.Framework.Audio.OALSoundBuffer..ctor () <0x000bc>
at Microsoft.Xna.Framework.Audio.SoundEffectInstance.InitializeSound () <0x0005b>
at Microsoft.Xna.Framework.Audio.SoundEffect.PlatformSetupInstance (Microsoft.Xna.Framework.Audio.SoundEffectInstance) <0x0001f>
at Microsoft.Xna.Framework.Audio.SoundEffect.GetPooledInstance (bool) <0x00093>
at Microsoft.Xna.Framework.Audio.SoundEffect.Play () <0x0001b>

Is there anything I can do about this except catch/consume the exception? Is this likely something specific to this one device or common to all S6’s (which are/will be a popular phone)?

Any help would be very much appreciated.

Sounds bad :frowning:
Might be worth posting on github too, I haven’t ran in to this yet.

Yep… it looks like there is some rror with S6’s. Same error I’ve got. Only on S6 phone.

For future readers - I did post on github, and it was “solved” by not building 64 bit. Here’s the issue: