Where is Pipeline.exe ??

Hey,ive been searching for hours hoping to find Pipeline.exe but i could not find it.Im using Windows 8.1 and i have the latest version of monogame.

1 Like

You should build it from sources, which are here: https://github.com/mono/MonoGame

Ok so i downloaded it and now what?There are lots of folders to choose from and everyone that i try to compile give me errors.

Edit: I think i need to build the project from Tools/Pipeline but that gives me 2 errors :smile:
Error 1 Metadata file ‘C:\Users\vlad\Desktop\MonoGame-develop\MonoGame.Framework.Content.Pipeline\bin\Windows\AnyCPU\Debug\MonoGame.Framework.Content.Pipeline.dll’ could not be found C:\Users\vlad\Desktop\MonoGame-develop\Tools\Pipeline\CSC Pipeline.Windows

The Pipeline is new… it isn’t in the MonoGame 3.2 release.

You need to build from source or install the latest development build from the downloads page. It is updated every time we commit new changes to the develop branch.

You don’t need to dig into any folders. Run Protobuild.exe from the root folder then open the MonoGame.Framework.Windows.sln and rebuild all. The Pipeline executable will now be built.

Don’t mean to take over someone else’s thread but I just tried that suggestion and got 981 errors, any suggestions?

@TBird, if you are getting too many errors, you don’t need to build from source. Like @Tom said, you can download the latest build here (I’ll assume you’re using Visual Studio on windows) and install MonoGameInstaller-3.2.exe which will be compiled from the latest source.

After you install, look in the folder
C:\Program Files (x86)\MSBuild\MonoGame\v3.0\Tools\

and you will find Pipeline.exe. You can create a shortcut to that location if you need.

If you don’t want to install, you can also get 7zip or your archiver of choice, open the .exe as an archive, and extract the folder named $_OUTDIR. You will find Pipeline.exe in there

5 Likes

@MrEMo…thanks, I don’t know how I missed this but it worked perfectly I thought that I ran the right one.

After you install, look in the folder
C:\Program Files (x86)\MSBuild\MonoGame\v3.0\Tools\

I’ve installed the version you linked and there is no “Tools” folder inside the “v3.0” folder.
I’m also not able to compile from source. Is there a standalone, prebuilt version of pipeline.exe I can download?

I’ve reinstall MonoGame 3.2 and I don’t have a directory name “Tools” in C:\Program Files (x86)\MSBuild\MonoGame\v3.0. It’s normal ?

I ran in to the same problem as you just an hour or so before you posted. I just realized I was looking in the wrong folder. make sure you look in C:\Program Files (x86)\ MSBuild \MonoGame\v3.0\Tools.
I missed the “MSBuild” part of the path and was looking directly in “MonoGame” inside “Program Files (x86)”. That seems like a really odd place to put the file, but I’m just happy to have finally found it.

2 Likes