Windows 10 Insider Preview (10122) appears to break content pipeline

After upgrading my dev machine (which is on the Windows 10 Insider Preview) to the latest “fast ring” build, the content pipeline throws an error whenever I try to build my content (from the MonoGame content file). Here’s the error:

System.DllNotFoundException: Unable to load DLL 'FreeImage': The specified module could not be found. (Exception from HRESULT: 0x8007007E)
    at FreeImageAPI.FreeImage.GetFileType(String filename, Int32 size)
    at FreeImageAPI.FreeImage.LoadEx(String filename, FREE_IMAGE_LOAD_FLAGS flags, FREE_IMAGE_FORMAT& format)
    at Microsoft.Xna.Framework.Content.Pipeline.TextureImporter.Import(String filename, ContentImporterContext context)
    at Microsoft.Xna.Framework.Content.Pipeline.ContentImporter`1.Microsoft.Xna.Framework.Content.Pipeline.IContentImporter.Import(String filename, ContentImporterContext context)
    at MonoGame.Framework.Content.Pipeline.Builder.PipelineManager.ProcessContent(PipelineBuildEvent pipelineEvent)

Can anyone else replicate the error or provide some suggestions for troubleshooting?

1 Like

Same I’m Getting The Same Errors in MonoGame Pipeline in windows 10 Build 10122. and I Don’t know what the Fix is. Could Someone Find a Solution or a Workaround

1 Like

I get this as well using 10130.

A resolution on GitHub issue #3556 (I can’t post links)
Solution was to install the x64 version of vs 2012 c++ redistributable

I created a very simple console app and I got this extra exception:

System.BadImageFormatException was unhandled
Message=An attempt was made to load a program with an incorrect format. (Exception from HRESULT: 0x8007000B)
at FreeImageAPI.FreeImage.CreateTag()
at ConsoleApplication1.Program.Main(String[] args)

Same problem here, I tried to install the VC2012 redist but I still have this error.
Windows 10 10130 too

I am running Win10 build 10130 and had the same problem.

Fixed the problem by reapplying the VS 2012 c++ redistributable (x64). For some reason the VCOMP110.DLL was missing.

Hi @FCatae I tried to reinstall the redistrubuable both x86 and x64, but I still have the issue with the latest revision

D:/Documents/Sources/C3DE/C3DE.Content/Models/Jack/PumpkinBump.bmp: error: Importer ‘TextureImporter’ had unexpected failure!
System.NullReferenceException: La r‚f‚rence d’objet n’est pas d‚finie … une instance d’un objet.
… Microsoft.Xna.Framework.Content.Pipeline.TextureImporter.Import(String filename, ContentImporterContext context)
… Microsoft.Xna.Framework.Content.Pipeline.ContentImporter`1.Microsoft.Xna.Framework.Content.Pipeline.IContentImporter.Import(String filename, ContentImporterContext context)
… MonoGame.Framework.Content.Pipeline.Builder.PipelineManager.ProcessContent(PipelineBuildEvent pipelineEvent)D:/Documents/Sources/C3DE/C3DE.Content/Models/Jack/PumpkinColor.bmp

I’m working on this right now. FreeImage is difficult to get right across platforms.

I’m still getting the error compiling Monogame.Samples. Is there a github issue for this already, before I start diving in blindly?

Same issue here with newest build #
System.DllNotFoundException: Unable to load DLL ‘FreeImage’

Finally, got it. I used dependency walker to see what’s wrong with FreeImage.dll. After some research I found that it was missing VCOMP120.DLL. I’ve installed Visual C++ Redistributable Packages for Visual Studio 2013 from here : and now it works like a charm. It is a little bit weird because I am using VS2012, not 2013 and I had redists for VS2012. Many hours spent digging … it should be added to installer !