WMAs produced by the pipeline have compression artifacts. Alternative options?

I recently started recording cello for the music in my game. I’m thrilled with some of the depth and uniqueness that I am able to add to the music by incorporating live cello.

However, I began to notice that when listening to the music in game on Windows, there seemed to be some tinny, unpleasant artifacts. I wondered if I was imagining them to an extent. But listening to the original WAV outside of the game, I wasn’t hearing the same artifacts. I asked my brother (a very reliable source :wink: ) to check it out to see if I was crazy, and he agreed that some “nasty artifacts were being produced.”

I tried exporting the source music in the OGG Vorbis format. Listening to the OGG Vorbis format, I am not hearing the unpleasant artifacts that I do from the WMA. Has anyone else experienced any similar issues, especially when including recorded instrumentals in the song?

Is it possible for me to use ogg as the output of the pipeline for a Windows desktop project? What are my other options? I tried lowering the quality of the song processor, and that may have removed some of the artifacts, but I don’t like the idea of having to make my songs low quality to try to work around compression/encoding issues.

I had never noticed any artifacts in the WMAs before adding live cello to my music. While it is true that my recording setup is far from professional, I have been really impressed with the mic (Audio Technica AT2020 USB+), and I’m not hearing the artifacts outside of the WMAs.

I don’t want to give up on incorporating cello, so any ideas or alternatives to work around this issue would be greatly appreciated.


I’ve found a way around this issue. I modified the source for the MonoGame.Framework.Content.Pipeline.dll to avoid having the conversion format of Windows Media (wma) be used for Windows. Instead, it now uses the default AAC (mp4) format, which, unlike the WMAs, do not appear to have any noticeable compression artifacts.

1 Like