Add templates for Visual Studio Mac

Weird. Sorry guys, there must be a bug somewhere :confused:

ok the latest version 0.6 , desktop GL should generate.
But it does expect to be using the latest develop I think. since it looks for the .dylib/.so files in the $(MonoGameInstallDirectory).

1 Like

Thanks @dellis1972 this appears to have fixed the template generator hanging. Should the Android platform be selectable at this point or is that still a TODO? I don’t have the Java dependencies installed so that could very well be a problem on my end.

Hmm, that looks like a bug. Only DesktopGL should be available atm. UWP should defiantly be disabled…
I’ll fix it. But at least its kinda working now. :slight_smile:

1 Like

at the moment i only get a empty project :confused: maybe i am doing something wrong? selecting only desktop, no code sharing and local/nuget?

Hey I’m running visual studio for mac, kinda new to the mac environment, I have installed mono develop, and monogame, yet I don’t see the template for monogame in visual studio. I have enabled the alpha channel and it does not appear. Any assistance would be grand!

Have you solve your problem ?

No I have not as of yet :frowning:

the add-in used to be there for me but now its gone :confused: for now just use monodevelop/xamarin studio to code with monogame until the add-in is back and fully functional.

Any update on this? I don’t necessarily need I on my Mac until the new year but to know they’re at least working on it would be good :slight_smile:

I also have this issue, can’t find the extension on alpha channel on mac. Would hate to lug around both pc laptop AND macbook, so would love it if i could get a solution (even if its just a temporary one)

you can use monodevelop for monogame on mac. there you still have the correct add-in that is fully functional.

Same here. Android and MacOS platform are not checkable.

I clicked the Refresh button after selecting the Alpha channel and the MonoGame addin appeared. If you don’t see the Alpha channel, select Manage Repositories in the drop-down menu and then make sure it’s checked. Once it’s installed, in the template chooser for a new project, you’ll see MonoGame under Other -> Miscellaneous.

1 Like

Tried to install Monogame on VS Mac in Manage Repositories and get the message:
"Could not get information from repository:"
When I click for Details:
Exception occurred: The remote server returned an error: (404) Not Found.

System.Net.WebException: The remote server returned an error: (404) Not Found.
at System.Net.HttpWebRequest.EndGetResponse (System.IAsyncResult asyncResult) [0x00059] in /Users/builder/data/lanes/4992/mono-mac-sdk/external/bockbuild/builds/mono-x64/mcs/class/System/System.Net/HttpWebRequest.cs:1031
at System.Net.HttpWebRequest.GetResponse () [0x0000e] in /Users/builder/data/lanes/4992/mono-mac-sdk/external/bockbuild/builds/mono-x64/mcs/class/System/System.Net/HttpWebRequest.cs:1043
at MonoDevelop.Core.Web.RequestHelper.GetResponse (System.Threading.CancellationToken token) [0x001fe] in /Users/builder/data/lanes/5402/b1c2982e/source/monodevelop/main/src/core/MonoDevelop.Core/MonoDevelop.Core.Web/RequestHelper.cs:251
at MonoDevelop.Core.WebRequestHelper.GetResponse (System.Func1[TResult] createRequest, System.Action1[T] prepareRequest, System.Threading.CancellationToken token) [0x00063] in /Users/builder/data/lanes/5402/b1c2982e/source/monodevelop/main/src/core/MonoDevelop.Core/MonoDevelop.Core/WebRequestHelper.cs:132
at (wrapper delegate-invoke) System.Func4[System.Func1[System.Net.HttpWebRequest],System.Action1[System.Net.HttpWebRequest],System.Threading.CancellationToken,System.Net.HttpWebResponse]:invoke_TResult_T1_T2_T3 (System.Func1<System.Net.HttpWebRequest>,System.Action1<System.Net.HttpWebRequest>,System.Threading.CancellationToken) at Mono.Addins.Setup.WebRequestHelper.GetResponse (System.Func1[TResult] createRequest, System.Action`1[T] prepareRequest, System.Threading.CancellationToken token) [0x00009] in /Users/builder/data/lanes/5402/b1c2982e/source/monodevelop/main/external/mono-addins/Mono.Addins.Setup/Mono.Addins.Setup/WebRequestHelper.cs:88
at Mono.Addins.Setup.AddinStore.DownloadFile (Mono.Addins.IProgressMonitor monitor, System.String url) [0x00154] in /Users/builder/data/lanes/5402/b1c2982e/source/monodevelop/main/external/mono-addins/Mono.Addins.Setup/Mono.Addins.Setup/AddinStore.cs:673
at Mono.Addins.Setup.AddinStore.DownloadObject (Mono.Addins.IProgressMonitor monitor, System.String url, System.Type type) [0x00002] in /Users/builder/data/lanes/5402/b1c2982e/source/monodevelop/main/external/mono-addins/Mono.Addins.Setup/Mono.Addins.Setup/AddinStore.cs:576
at Mono.Addins.Setup.RepositoryRegistry.UpdateRepository (Mono.Addins.IProgressMonitor monitor, System.Uri baseUri, Mono.Addins.Setup.RepositoryRecord rr) [0x00028] in /Users/builder/data/lanes/5402/b1c2982e/source/monodevelop/main/external/mono-addins/Mono.Addins.Setup/Mono.Addins.Setup/RepositoryRegistry.cs:334

OK, I reinstalled Visual Studio for Mac a couple of times and the last time I tried to enable the Monogame extension again. I received the same message as above but this time a progress window flashed briefly as if something was loaded. Checked extensions and Monogame was there and I was able to add it. Don’t know what changed or how it worked but it does now. Go figure.

Thanks to gee4vee i have now the template, but the MacOS is not checkable, also the iOS version doesn’t run, it says is linking to the simulator but nothing happened. Any idea?

Have you installed Xcode IDE? because visual studio for mac uses the simulator from Xcode to run.

A new Template Adding for Visual Studio for Mac is up in the beta channel its called MonoGame Extension . Code should be merged into the Repo in a few days and will be included in the Mac Installer.


Hi @dellis1972, I found that the cross-platform OpenGL project generated by the new extension report an error on VS for Mac, it says Invalid Configuration Mapping.

Also there’s error while building because MonoGame did not install multi-architectures targeted dependencies, I remove the x64 and x86 directories and all .dylib files from the project and refer MonoGame.Framework.DesktopGL from nuget instead of the local framework installation, it works well.