App Store publishing error

Hello,

Whenever I try to publish my package on app store, I get the following message:

ITMS-90713: Missing Info.plist value - A value for the Info.plist key ‘CFBundleIconName’ is missing in the bundle ‘test.Test.lajbert’. Apps built with iOS 11 or later SDK must supply app icons in an asset catalog and must also provide a value for this Info.plist key. For more information see http://help.apple.com/xcode/mac/current/#/dev10510b1f7.

The solutions I found online were either not working on not applicable:

  • I have the tag added to my info.plist

    <key>CFBundleIconName</key
    <string>GameThumbnail.png</string>

  • The other solution was adding some .xcassets files to my project, but that does not applicable in VS, at least I only found it to be possible in XCode which is not usable with MonoGame.

Anyone has any guesses what this might be?

Thank you

I’ve even tried adding xcassets based on this thread, but it’s also not helping:

It should require both those bullet points you listed. When it says it requires a bundle icon, it really means that .xcassets asset catalog, not a single image. Hard to say what the problem is without seeing your exact assets and project setup, but I would experiment more with the .xcassets and listing it in your Info.plist.

Thank you so much for the reply. I tried messing around with the property, this is how my project setup looks like currently:

For the CFBundleIconName property I tried to set only ‘AppIcon’, ‘AppIcon.appiconset’ and also the value you see on the screenshot. The asset catalog is called Images.xcassets, I generated it using visual studio and filled it with temp images from the web from the stackoverflow thread from the previous reply.

Still nothing. Any idea what I might be doing wrong here?
Also, the project is open source, but I did not commit this specific part yet, I will once I replated the placeholder “Unity” images from the asset catalog :slight_smile:

I believe “AppIcon” is correct. Did you try the part in bold from that StackOverflow post about removing and converting the images? Do your images show up in a list if you select Images.xcassets on the left? I would have expected a dropdown arrow there but I haven’t done this myself in a while.

1 Like

Okay so after many days of struggle, I got it done…
I’ve added a new asset catalog file and manually dropped in all the icons with the proper size.

After that, adding the CFBundleIconName wasn’t enough, I also had to add this tag to make it work:

<key>XSAppIconAssets</key>
<string>Assets.xcassets/AppIcon.appiconset</string>

Once I’ve added this tag, it magically started working!
Also, it’s important to add all the files (asset catalog and all the jsons and images used by it) to the solution file as well.

1 Like

hai sir I am facing same issue in last 10 days almost I uploaded 35 times in App Store plss help sir

plss help sir