Can't get MonoGame to work in VS2017 Community (SOLVED)

I have tried everything to get MonoGame working in VS 2017 Community but it just won’t work. I have tried all of the fixes I have seen on Google and on this MG community site, nothing is working for me. Has anyone got any other suggestions? I am running the latest version of VS2017 Community on Window 10. I have tried the dev version of MG and 3.6, 3.7, 3.8 and none of them work. I never see the project templates in New Project dialog under Visual C#. I have repaired VS2017 and even uninstalled and reinstalled it and MG and still no joy!

What system and are you admin or is this a school computer?

This is my home computer Windows 10 and I am admin. Ran MG install as admin, ran VS install as admin. This is a monster gaming computer with 32 GB ram and overclocked everything and huge HD.

Well, it works in VS2015 Community, so I guess I’m freaking stuck using that version. I hate you Microsuck.

Look at the 4th message in Monogame & Visual studio 2017 , and check that the folder (documents/vs2017/…) exists for your user.

If that folder is not there, this is probably the cause of your problem. If so, Manually create mentioned folder and reinstall again MG


I had already seen all the posts on this Community about this issue and none of the solutions work for me.

What antivirus stuff are you using?

no idea, then, I’m sorry.

BTW, there’s no need for you to work with VS2015. You can just create the project with VS2015, and then open it to VS2017. If it’s just a Templates problem, it should work.

1 Like

I use WebRoot and that shouldn’t be an issue since the MonoGame projects appear in VS2015 with no problem. VS2017 is seriously broken. You can’t even make a template from an existing project without having to do things manually and they have still not fixed that.

  • On my case I just copy the Monogame template of VS2015 to “ALL” user document templates of VS2017 and the templates project appears in VS2017.

  • If still doesn’t work then, KatKat solution is the work around to open the project on VS2017.

1 Like

I will try that later. Thanks everyone for your input.

VS2017 has pretty much been a dumpster fire.

1 Like

FINALLY! I got the templates to appear! I had to move the MonoGame folder that has all the project templates up one folder out of the Visual C# folder. The path is now:
%userprofile%/documents/Visual Studio 2017/Templates/ProjectTemplates/MonoGame
And it shows up under Visual C# in the New Project dialog. Really weird!

Maybe this will help someone else having the same issue.

1 Like

That does seem peculiar indeed

1 Like

Cool you got it working… in any rate the template directory can be change from teh menu under Tools->Options

My project template directories were set correctly when it did not work, and are still set the same as in your screen shot now. I just had to move the MonoGame folder out of the Visual C# folder up one and it worked.

Beware, MS-build extensions break regularly in VS2017. If you get stuck in an infinite rebuild there’s a good chance it’s going to be from the extension for the MGCB build, it’ll get trapped in a loop of believing content hasn’t been built.