Content Pipeline Tool not executing/launching

I’ve been searching online for a solution and am unable to figure this out.

I decided to get back into programming and hopefully develop something in mono, I decided to install the development branch, I didn’t uninstall the last version of monogame before installing the development one that could be a source of the problem but I figured it would simply override the previous version installed.

I can’t get the pipeline tool to open, I’ve tried removing my settings from the isolated storage like one thread recommends however a new settings wasn’t created when I tried to launch the pipeline tool.

Any suggestions are welcome. I’m not the most tech savvy though.

The app or the link in VS?

And give a go on the release versions and try a reinstall to see if you broke it perhaps?

Also, @Darren2k34, Welcome to the Forums and Happy Coding!

I tried both, the link in VS and the app in the folder. Neither did anything. Okay I’ll try the original version. I was hoping since the original hadn’t been updated in 2+ that the development branch would have the Video class working. I wasn’t able to use the class in a Windows project last time I tried.

for some reason the stable version does fix this problem, will this be fixed soon in the development version?

1 Like

Ask @Jjagg

When you say “install the development branch,” do you mean you cloned the repo, checked out the develop branch, and ran in Visual Studio?

If so, did you open MonoGame.Tools.Windows.sln? And then which project did you run?

Nope I downloaded the installer under the development build tab

" MonoGame for Visual Studio (requires a 64bit version of Windows, VS2013, VS2015, or VS2017, and the latest DirectX Runtime)"

If things dont have an installer then I personally am clueless to how to get them onto my machine without some kind of walkthrough.

1 Like

Same here. The latest dev build of the pipeline tool doesn’t launch…

Are there any errors? I think it produces a log somewhere, but you could also try opening the Windows Event Viewer and looking in Application logs.

You have to use the 3.7.1 installer, the dev build will not get any updates.

If you want an up to date SDK you can use my own build.
The installer contain templates for VS2019 and the redistributable required by FreeType.

The libraries have all the commits up-to-February 2020 but also contain a lot of extra changes.

@jnoyola Here are the errors…
Error 1:
Application: Pipeline.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.InvalidOperationException
at Eto.Platform.Get(System.String, Boolean)
at Eto.Forms.Application…ctor(System.String)
at MonoGame.Tools.Pipeline.Program.Main(System.String[])

Error 2:
Faulting application name: Pipeline.exe, version:, time stamp: 0x5e560652
Faulting module name: KERNELBASE.dll, version: 10.0.18362.815, time stamp: 0xb89efff3
Exception code: 0xe0434352
Fault offset: 0x000000000003a799
Faulting process id: 0x4e04
Faulting application start time: 0x01d632a8dd238fd3
Faulting application path: C:\Program Files (x86)\MSBuild\MonoGame\v3.0\Tools\Pipeline.exe
Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll
Report Id: e57f250b-9fdf-4db2-8be5-1cf37430dcde
Faulting package full name:
Faulting package-relative application ID:

@nkast Thanks for your build! The pipeline tool launched successfully. However, there was an error when I tried to build an effect file, which can be built successfully by an older version of the pipeline tool:

error : Processor ‘EffectProcessor’ had unexpected failure!
System.TypeInitializationException: The type initializer for ‘TwoMGFX.ShaderProfile’ threw an exception. —> System.ArgumentNullException: Value cannot be null.
Parameter name: source
at System.Linq.Enumerable.FirstOrDefault[TSource](IEnumerable1 source, Func2 predicate)
at TwoMGFX.ShaderProfile…cctor()
— End of inner exception stack trace —
at Microsoft.Xna.Framework.Content.Pipeline.Processors.EffectProcessor.Process(EffectContent input, ContentProcessorContext context)
at Microsoft.Xna.Framework.Content.Pipeline.ContentProcessor`2.Microsoft.Xna.Framework.Content.Pipeline.IContentProcessor.Process(Object input, ContentProcessorContext context)
at MonoGame.Framework.Content.Pipeline.Builder.PipelineManager.ProcessContent(PipelineBuildEvent pipelineEvent)

That was a bug indeed, I updated the SDK in the same link as above. It should work now.

@nkast Thanks a lot man! Really appreciate your help! This time the effect file was built successfully without any error. However, when I replaced the effect file and ran the project, the same error still showed up:

This MGFX effect is for an older release of MonoGame and needs to be rebuilt.

I am using the latest MG source on the dev branch, and I have no idea what was changed recently regarding MGFX effects… :frowning:

That’s the change
It looks like you can’t mix different versions of runtime / pipeline after that commit, and I still haven’t catch up to this point.

You can use the build in runtime libs from the SDK
(C:\Program Files (x86)\MonoGame\v3.0\Assemblies)

If you are working from MG source then you can build your own 2MGFX/MGCB/Pipeline to be in-sync.

Alternately you could add fallback code in Effect.cs to be backward compatible with MGFX version 8.

Thanks for the suggestion! I tried opening the MonoGame.Tools.Windows solution, but encountered several errors with .NET SDK:

Then I installed .NET core SDK 3.1 (both x86 and x64 versions), but those errors didn’t go away. Also there seemed to be some missing dependencies. Since I don’t have much experience with building MG tools, it can be a bit messy and time-consuming for me to deal with those errors…

I wonder if there is any chance that a (relatively) stable version of the latest MG pipeline tool gets released soon? Thanks very much again for your help!!

3.8 prerelease was just announced today :smiley: I recommend trying that.

# to install globally
> dotnet tool install --global dotnet-mgcb-editor --version

# to run
> mgcb-editor

And yes, this tool does indeed require .NET Core SDK 3.1

Full docs detailing these steps and more are going to be published soon.


Wow! Do you have a download link to the installer of 3.8 prerelease? :smiley:

With 3.8 there is no more installer. Everything comes as NuGet packages and dotnet tools. The one line I gave above is all it takes to install the MGCB Editor (the new “Pipeline Tool”).

EDIT: I understand that may be confusing if you’re not as familiar with these topics. If you’d like additional explanation, I’d be happy to go further into the details.

Thanks for your explanation! I installed the MG3.8 prerelease NuGet package with the first line. But when I tried to run the second line, there was this error:

‘mgcb-editor’ is not recognized as an internal or external command, operable program or batch file.

Not sure what the problem was…