Game stutters on iOS when resuming from app switcher or unlocking phone

Hi,

Can someone please point me in the right direction.

I have a blank app with basic constant floating blocks on screen.

On iOS when the game is running, when I activate the app switcher and return to the game or lock my phone and unlock, the game stutters (for only several milliseconds but noticeably).
The stuttering is only once and as if the floating blocks skipped a beat and moved further than expected (caught up).

Why does this happen?
Does the game’s content get reloaded when switching apps?
Could it be the elapsedTime is still continuing while the appswitcher/iphone lock is transitioning?
(note: I have tried removing elapsedTime from the Update() method and directly just incrementing the position, but the same stuttering happens)

I don’t have any sample code to produce but my code does not do anything complex and my assets are only 2D tiny images (but maybe enough to assume maybe the content is reloading all the images hence stutter?). In the code loading of the assets is only done once on load.

I’ve had a look at similar articles 1 2 3 but they don’t seem to relate

Upon further inspection, this behaviour seems to be the same on Android as well (but more smoothly - where there’s a slight transition into the stutter, not just a skipped couple of frames like on iOS).

Unsure if this is related to the Fast Resume issue.

Some other useful articles


The issue I’m facing however is not the screen going blank as outlined in above articles, but rather a one-time stutter (couple of frames skipped) when the app is reopened.

Any insight to this would be greatly appreciated :slight_smile: