How to install Monogame 3.2 in Ubuntu 14.04?

Thanks! Installation worked great (except from the little error you mentioned).
I now have the option to create a content-project from File->New->Solution

I’m probably doing something wrong, but following I have the option to add a SpriteFont, but I can’t get it to process say a png-file (not an option in Add->New file, and when adding a png-file and right clicking it and clicking Properties I don’t get any more options than before :confused: )

Well well, will look into it more later. Once again, thank you very much :slight_smile:

So I actually have an error to fix… Well anyway, for now you can use this extension, I think… :

It’s the official monogame content extension. Also it never actually worked for me, I just used xnb and png files(placed them in folder Content, set build action to content, and set copy to output directory to only when newer).

I forgot to include a dependency, here fixed(installation error still occurs):

Monogame Content addin for monodevelop 4:!bIAzgaDI!-aomQYJYr-sQt_4cNAGC_OOmC0rcRkn1n7dBFzHjUHg

Monogame Content addin for monodevelop 5:!iRQhXbTA!ERp3z_psUQHNBKgM-_9lATU6Q3vT8tirwX_mFBRgtqc


Now it works! Great

If I understand your png/xnb setup correctly, I think we’re doing something similar. I did something like:

  • One solution with my MonoGame Linux-project as well as a content-project.
  • I add my png:s to my content-project and in the png:s properties I set it to compile and use TextureProcessor.
  • In my MonoGame-project I choose to “Add files” to its Content-folder, selects the resulting xnb-file from the content-project and adds it as a link instead of a copy. I then select “Copy when newer” like you did.

Something like below

  • MyContentProject

    • Content
      • img.png (TextureProcessor, Compile)
  • MyMonoGameProject

    • Content
      • img.nxb (Link to MyContentProject’s resulting xnb-file)

Seems to work just fine :slight_smile:

Can you please re-upload the Monodevelop 5.x add-in for Monogame 3.2? Thanks!

Thanks for notifying me that links didn’t work. I switched to MEGA and forgot to leave monogame folder behind on dropbox, now it’s fixed.

I always used my PNGs the same way (set to content and copy if newer). So my question is why would I need to use anything else like using the content template for MonoDevelop?

The only reason that I know of why textures should be compiled is so that players cannot modify them.

Ah that makes sense, thank you for answering my question

I’ve manually compiled MGCB for linux and added/changed some code for Fonts and 3D Models to work. I’ve also added a GUI tool called “ContentProcessor.exe” so that you don’t have to compile from terminal.

Link to download:!qAwBCBaZ!msP736fZGQNI3PeHUyQtbIRT3jriFXMd3Tv0UoSzb5U

PS. To use 3d models from blender, download blender from the website, open it, go File > Export > Autodesk FBX, on the left panel select FBX 7.4 binary as version and export it wherever you want.

Monodevelop 5.7 broke everything. If your monodevelop isn’t starting delete all the folders in ~/.local/share/MonoDevelop-5.0/LocalInstall/Addins. Also addin for monodevelop 5.7:!iIhklRyS!Vhgbc0Jn9AIdTevBvyiv_4hP8P5Rg_kBMn_zC8n0DIM

Many thanks for posting this and your earlier work! I have been using your mpacks. Have a question about your MGCB with the GUI. It mostly works for me, except my *.x models do not have any material or texture properties. I use the ModelProcessor and Ximporter. I have been using AC3D 6.1 to make models and export them as *.x files. Its an older simple Windows based modeler. This worked well for XNA and for MonoGames 3.2 with Visual Studio. I’ve tried many export settings all with same result. Any suggestions or settings to try?

Monogame Pipeline Tool for Linux:!yEIHGLjS!OvjruaOdTQmgmTY4RvXLZw

1 Like

Try loading the texture for the model manually within the code. Anyway I know about the bug, I just don’t know what’s causing it.

Where would I go about learning how to compile these .mpack files myself? Thanks! :smile:

For writing addins:

For publishing addins:

Also if you already knew that and just ment how to compile mpack from dll, the command is:

mdtool setup pack myaddin.dll

Is there any reason this link is down, or did I miss something?

Really appreciate all of your work with these add-ins

Ups, I guess you are talking about pipeline tool, I moved it to a folder:!yEIHGLjS!OvjruaOdTQmgmTY4RvXLZw
so I could update the tool without updating the link. I thought I had changed it, my bad.

Edit: Updated link:!PQxCCYoQ!3LQ5JglFwFExQnXqvDIoKA

PS. The new monodevelop addin built by dellis:
If you want to download it scroll to the bottom, there should be a link there.

Note to anyone trying to uninstall older version of monogame pipeline, do:

cd /opt/monogame-pipeline/

First cd to the directory and then call the uninstal script. Do this because the uninstall script will remove the working directory instead of the directory in which it is located. I’ve updated pipeline today with the version that is safe for uninstallation by calling the sh script from anywhere.