Monogame on Raspberry Pi

What’s the latest on Monogame and the Raspberry Pi? I’m running Raspbian on a Pi and have cloned the monogame repo and built it on the Pi. Got Monodevelop installed too and wanted to try a simple program. Built the Templates and according to the readme
MonoDevelop Addin Installation for Linux

  1. Shutdown MonoDevelop
  2. Press Alt and Drag and Drop the directory MonoDevelop.MonoGame into ~/.config/MonoDevelop/addins (/usr/lib/monodevelop/AddIns since MonoDevelop 4)
  3. Restart MonoDevelop and these addins should now be available

Although monodevelop on the pi seems to be version 3.0.3 there is a (/usr/lib/monodevelop/AddIns directory. I copied the MonoDevelop.MonoGame folder here but I don’t get anything new when I create a new solution. Within the MonoDevelop.MonoGame directory that is built there are other MonoDevelop/MonoGame directories so should I have copied one further down the chain?

There is nothing special about Raspberry Pi, it’s just a machine running linux, so… How to install Monogame 3.2 in Ubuntu 14.04?
also do get the newest monodevelop from

Yes, I’ve been trying to treat it as “normal Linux” now that all the hardfloat issues seem to be resolved with mono. Does Monodevelop 3 not work then? I’ll see if I can build 5.7.Even if I do get the new version, which directory needs to copied to Addins? Is it the top level MonoDevelop.MonoGame one with the readme.rtf file or a lower down one?
Thanks for your time.

There is a little bit of special hacking required as it is not just a normal machine running Linux.

I did not expect Raspberry Pi to use OpenGL ES, so I also stand corrected, there is something special about Raspberry Pi

Had seen those before and hoped that as they were using monogame 3 that 3.2 may have progressed things a bit, which was why I was quite pleased to have been able to build it!.

Tried building monodevelop 5.7 but so far got stuck on gnome-sharp as a dependency. Have cloned the git repo for it but ./configure won’t run on it.

What linux are you using?

Raspbian which is debian wheezy for the Raspberry Pi.

Is monodevelop ubuntu/debian repository from not working for you?

I used apt-get to get monodevelop and that was what got me version Have cloned the git repository for monodevelop to build and install the latest version as you suggested but it won’t build due to a dependency on gnome-sharp. Couldn’t find a package for that so cloned it’s git repo too and that’s where I got stuck as ./configure would not run for it. It has a file though, any idea how to use that although README says ./configure should work? Got it, have to run bootstrap instead, but now am off down the rabbit hole as more dependencies are required to be built!

I’m not running wheezy main as I wouldn’t trust the binaries to be suitable for the raspberry pi. So just using the default raspbian repository.which is probably why it is quite a way behind.

What Raspberry Pi model do you have?

Old model B, so 256M RAM instead of 512M.

I am gonna borrow Raspberry Pi from a friend this Saturday, coincidentally he also has old model B.

:slight_smile: Great. WiIll try and get some time this evening. I got stuck on a requirement for gapi-2 which seems to be part of gnome-sharp I think it was. Built that and installed but still get a requirement for gapi-2.

Well finally got to build monodevelop but failed at the last

            78 Warning(s)
         36 Error(s)

Time Elapsed 00:10:30.3747720
Makefile:1051: recipe for target 'sln_build' failed
make[2]: *** [sln_build] Error 1
make[2]: Leaving directory '/home/pi/gitrepos/monodevelop/main'
Makefile:581: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/home/pi/gitrepos/monodevelop/main'
Makefile:22: recipe for target 'all-recursive' failed
make: *** [all-recursive] Error 1``

Also created a virtualbox VM running Debian and got monodevelop 5.7 running. Still cannot get templates for monogame to appear. What need to be copied to /usr/lib/mondevelop/AddIns ? so ARMv7 and 6x the performance. Also Microsoft are supplying a free version of Windows 10 to run on it. Could be interesting?

It could be, but I wouldn’t expect much in the way of high performance graphics on Windows 10 for IoT. It’s primary aim is for headless, unattended devices. It also may not even have the full .NET Framework, but rather .NET Micro Framework which is currently not a usable environment for building MonoGame.

Let’s see what happens. There simply isn’t enough information yet to make any determinations on what might be possible.

I got my Raspberry Pi 2 working last night, installed Windows 10 on it, and ran the existing MonoGame Windows 10 Universal App on it… and things “Just Worked”!

The performance was poor, but it was connected to a debugger at the time and it is an early version of Windows 10 for RP2.