I Can't Setup Monogame For Mac

I know there is documentation telling me how to setup, but it doesn’t work when I follow the steps.

So I downloaded the MonoGame.Templates.VSMacExtension_3.8.1.263.mpack from Release MonoGame v3.8.1 · MonoGame/MonoGame · GitHub.

Then I installed the extension to visual studio.

However, the monogame extension inside the “Extension Panel” is “Disabled”. I cannot enable it either.

I would like to ask did I missed some steps or I have to install something else first.

Link the guide you followed.

Welcome back :sake:

1 Like

I follow this guide for reference:

I also recorded another video about how I setup Monogame:

It’s “Disable” and cannot be enabled. There’s no monogame template when creating new visual studio project. idk why it won’t work…

Not a Mac developer so hopefully someone chimes in.


1 Like

monogame is installed correctly on your computer in the meantime you can create your project on the command line here is the list of the different platforms:
dotnet new mgdesktopgl -o MyGame
dotnet new mguwp -o MyGame
dotnet new mgios -o Mygame
dotnet new mgandroid -o Mygame

1 Like

It is also necessary to install the last correction of monogame3.8.1 MonoGame.Templates.VSMacExtension_3.8.1.303.mpack

1 Like

Thank you for all helps!! It works now!
Turns out I was just dumb… The extension panel said Monogame Extension is disabled, but I can actually find it after clicking “Create New Project”.
You guys all so nice! Thank you!
I can work on my tile engine now.

1 Like

I just downloaded visual studio 2022 for mac and I can’t install the MonoGame.Templates.VSMacExtension_3.8.1.303.mpack. It complains that it want version 17.06 of the monodevelop lde and core libraries but has found 17.4. Does anyone know how to fix this?


Same problem here:

The add-in ‘MonoGame.Templates.VSMacExtension,’ could not be updated because some of its dependencies are missing or not compatible: required: MonoDevelop.Core,17.0.6, found: MonoDevelop.Core,17.4.2 required: MonoDevelop.Ide,17.0.6, found: MonoDevelop.Ide,17.4.2


I am seeing this too.


I got mine working when I changed to the VSMacExtension version
Solution is mentioned above but no link was provided, you can get it from here: Release MonoGame v3.8.1_HOTFIX · MonoGame/MonoGame · GitHub

I think I got the same error about not being compatible, but it did install the extension and then MonoGame template-projects are available after that. Create new MonoGame-project to test out it is working, build and run.

check releases page for the latest packages: Releases · MonoGame/MonoGame · GitHub

The getting started guide links to the version, I think it should be updated.

1 Like

Hi @Jho, welcome to the community.

Thanks for sharing this information, I’ve put in a PR to update the documentation to point to the correct release page Correct Mac Getting Started Documentation by AristurtleDev · Pull Request #8048 · MonoGame/MonoGame · GitHub