Install MonoGame 3.2 with Xamarin Studio on Mac OS X


how can I install the project templates for MonoGame 3.2 for Xamarin Studio 5.1.2? I am using Mac OS X. I searched, but cannot find any information on that. There is no package or installer for the most recent version of MonoGame for Mac OS X, so what do I have to do to get this done with the source code from GitHub?

Thanks for your help

1 Like

I have the same problem, except I’m running on Windows. The closest thing I could find was a tutorial for Mac OS X.

The problem is that the MonoGame for Xamarin link seems to be dead, and there’s no up to date replacement for 3.2.

EDIT: This video shows pretty damn well how to set up MonoGame.

There is a MonoDevelop plugin that resembles the Windows Installer for Visual studio, however it hasn’t been updated yet for the latest 3.2 release.

There are however the NuGet packages which include templates for most platforms, if you get NuGet working in Xamarin Studio you can install it that way in to a blank project.

So basically what I have to do is to create a blank project and add references to MonoGame to it?
I try to get NuGet working in Xamarin Studio and add MonoGame that way. Then I will see what is needed to start.

We really need to find a hero that will volunteer to fix or replace the old addins with a new set of templates that integrates with XamarinStudio.

1 Like

NuGet comes already installed with Xamarin Studio 5. So created a blank solution and project and added the package MonoGame to it (version 3.2.0). But when I try to run the project I get the following error:

The type or namespace ‘Xna’ does not exist in the namespace ‘Microsoft’. Are you missing an assembly reference?

I had to add the assembly reference manually. I found it in the directory of the package added by NuGet:


When I tried to run it this time I got the following error at the constructor of the subclass Game1 of the class Game:

System.IO.FileNotFoundException has been thrown
Could not load file or assembly ‘MonoMac, Version=, Culture=neutral, PublicKeyToken=null’ or one of its dependencies.

How can I solve this problem? Where is that file usually located, because I don’t seem to have it or the wrong place is searched for it.

@stebyrne04 seems to be close to that, but looks like he’s still having some trouble. Cheers!

This mpack worked fine for me, except that the Android template Activity1.cs is not on par with the recent changes on the repo (looks to be built upon the 3.2 release).

The mpack worked for me also (at least the Mac template). Thank you for it.

I think it’s vital to at least show in the documentation how to set up MonoGame for every platform properly (with and without add-ins). For me wanting to get started quickly this was not a trivial task. Without the mpack mrhlemut posted I would not be able to begin develop with MonoGame as no information Google gave me solved my problem.
I would contribute if I had the knowledge.

1 Like

I quote that, users definitely need some quickstart guide and if only i had the time i would do it myself…

i have found a way, by installing os x yosemite and installing it you don’t get any error

Can you please share the steps of how you installed monogame ?

Hi! I recently got a macbook to develop games for iOS. The installation process was quite painfull, but that was just because I didn’t knew how to set everything up properly. However, the installation process is actually quite simple, once you know how to make it work hehe. Here’s what you gonna do:

First of all, download Xamarin Studio. You get also get a free 30 days trail, so I activated mine at this point.

Then you need to setup your environment properly using the instructions found here!

When everything is activated it’s time to create some games! Just follow these simple steps and you should be up and running!

Good luck mate :wink:

1 Like

@philip , What version of Xamarin do you installed?, Can you please post the steps of how you installed monogame with xamarin ?

I’m using Xamarin Studio 5.3. I did post the steps of how I installed MonoGame. Just follow the links and you’ll be done within minutes. However, you won’t get any MonoGame project options when creating a new project, just create an empty one and add MonoGame as a NuGet package (as shown in the last link).

I wouldn’t mind helping out - although I don’t know much about it - where are the old mpack sources that I could look at?