Installing MonoGame for Visual Studio for Mac not Working

I have followed the instructions on how to install MonoGame for Visual Studio for Mac, but none of the templates show up when i try to create a project. I have followed the tips and instructions in this thread: Add templates for Visual Studio Mac but with no results. Any tips? I have installed Mono 5.18.1, Visual Studio for Mac 8.0.4 (Community) and MonoGame 3.7.1.

4 Likes

Same here, with same versions. Is there anyone else with similar issues?

yep, same, doesn’t show up in templates

same here. it worked for me untill the previous vs for mac(with some missing templates like cross platform). with the 2019 version the templates are completely gone.

same issue, updated by accident, now I can’t figure out how to start a new project, microsoft won’t let me download 2017 either :-/

I wasn’t able to get the templates working with Visual Studio 2019, but they did start working once I installed Visual Studio 2017. You can VS 2017 for the Mac at MacUpdate

I tried downloading the 2017 version and it did not work for me. I also tried uninstalling everything and doing the same steps except with the 2017 version instead, but still no templates show up. Did you do anything specific with the 2017 version or did you just have to install it?

EDIT: I tried uninstalling everything and installing it again using 2017 version and somehow it worked the second time! Don´t know what i did different the second time though. Thank you for sharing this solution!

That just installs VS 2019 version

This is the reason for the problem. The MonoGame extension is not compatible with the latest version of Visual Studio for Mac. There are 2 possible solutions for this.

Either downgrade Visual Studio for Mac by uninstalling the current version and then get the older one from here : https://visualstudio.microsoft.com/vs/older-downloads/ After that, continue to follow the installation instructions in the MonoGame documentation here : http://www.monogame.net/documentation/?page=Setting_Up_MonoGame_Mac

If you are not in hurry, you can wait for MonoGame to be updated to support the latest version of Visual Studio for Mac.

What Monogame version works with the latest version of Visual studio code for mac? (7.8.4)

3.7.0 or 3.7.1?

I am not sure about MonoGame v 3.7.0. But v 3.7.1 of MonoGame works with Visual Studio 2017 for Mac (v 7.8.4).

To clarify, Visual Studio Code is a different IDE and not the right one for MonoGame.
Additionally, Visual Studio 2019 for Mac (v 8.0.9) is the latest version of Visual Studio for Mac and does not support MonoGame v 3.7.1.

1 Like

Thank you about the clear information! 7.8.4 works for me (with Monogame v3.7.1)

I worked with VS Code before and was confused!

you can use visual studio code but you will have create project via the terminal and get .net core version

Eh, I still get the exact same error as @SaViS
It seems like a simple extension that AFAIK only has a few templates, should not break between VS updates. I mean, how much can change regarding project templates?
Either the extension is too strict in the visual studio version requirement, or VS for mac is breaking stuff between releases.

I guess it’s the first case, only a matter of version requirement. I’ve been waiting for an update since my previous post, reluctant to reinstall the previous version of Visual Studio for Mac.

It’s better to downgrade or of that’s not possible, move on to a different game engine.

That’s really too bad because if that’s the case, then it should not be difficult to fix, but without the fix it’s just really hard to get started.
The difficulty to get from 0 to a hello world example is way too high.

You could also use the .net core version of monogame within vs code on the mac. It works for me :slight_smile:

See this link: https://stackoverflow.com/questions/41198337/is-it-possible-to-use-monogame-in-vs-code

make sure you have installed .net core etc