MGCB generated content on iOS

Experiencing a couple of difficulties with content generated by the content builder tool in the iOS port of my game:

  1. Trying to load a song results in a ContentLoadException being thrown - which is very odd, considering that another tune that I have in another test app and that was generated by the content builder plays correctly…

  2. The spritefont does not appear in much the same way that (as far as I remember) a “bad” spritefont generated from XNA game studio would not appear. The font in question was created in the content builder by Edit -> New Item, then altering the resultant .spritefont file to use Arial 36point.

Any ideas?

Okay, done a bit more digging…

Got a sneaking suspicion that the music problem is down to a Xamarin update, as my test project that worked previously now falls over with the following error:

“Could not initialize an instance of the type ‘Monotouch.AVFoundation.AVAudioPlayer’: the native ‘initWithContentsOfUrl:error’ method returned nil.”

Although my new game project is for the unified API as opposed to the classic, I’m pretty sure this is the problem, although unfortunately I do not currently have anything set up to test it.

Can anyone else confirm that they have had this issue?

Regarding the spritefont - still no luck. I downloaded the mac version of the MGCB pipeline tool and built a spritefont as before (new project, edit, new item, updated the xml to 36 point, build), but this does not work either - my font is still not rendering, very frustrating! So any input/updates on this or details on how to fix the problem would be very welcome!