MGCB Not Launching on macOS M1

Hey everyone,

I’m using MonoGame for a class at school, and I cannot seem to open the MonoGame Content Builder. I double click on the Content.mgcb file in Visual Studio 2022, a MonoGame icon briefly pops up in my dock but closes before there is any output. I’ve tried the most recent version of the .mpack (which I have to disable and enable every launch for some reason), but cannot get this to work. I am running the most recent macOS version (12.5.1) and using an M1 Max processor. A fellow classmate is also using a Mac but with an x86 processor, so I’m curious if my problems lie with Apple Silicon?

If anyone could help or let me know how to send logs here, that would be awesome! Thank you!


Have you tried running MGCB from the command line?
in the terminal

dotnet mgcb-editor

→ then manually import your Content
you have to go in

cd ~/.dotnet/tools/

uninstall global version

dotnet tool uninstall --global dotnet-mgcb-editor

and reinstall
the last version

dotnet tool install --local dotnet-mgcb-editor --version
1 Like

I had issues also until I installed the x64 version of dotnet. You can download it here Download .NET 6.0 (Linux, macOS, and Windows) I installed it alongside the arm64 version that’s installed with Visual Studio for Mac


Quoting the documentation:

However , it is not yet possible to use the MGCB or the MGCB Editor on Apple M1 silicon, unless you are running the osx-x64 variant of the .NET SDK (and therefore using Rosetta emulation). We are working toward resolving this inconvenience.

1 Like

MGCB works fine on M1 Macs, I’ve been using it for the last 2 years on an M1 Mac.

On a Mac MGCB is inside of Visual Studio for Mac. There is not a separate MGCB application that you need to install like you would on Windows.

To use MGCB on a Mac, click on the Content.mgcb file in Visual Studio and then a tab called “Monogame Content” will open inside visual studio on the left side of the screen right next to the solution tab. That tab that popped up is your MGCB editor. It may be in a slightly different place on Visual Studio 2022. I use Visual Studio 2019.

Yes, you have right. It works under VS2019 and older version of MGCB/MonoGame. But we talking about VS2022 and newest version of MGCB which is not working at all :slight_smile: As they said on MonoGame doc page - " it is not yet possible to use the MGCB or the MGCB Editor on Apple M1 silicon"

Hey, wondering there are still problems with mgcb on m1?

I still can’t get it to run by double clicking or right clicking from inside VS2022, but I was able to get it working by going to the Content folder of my project and running it via dotnet mgcb-editor