MonoGame 3.7.1 and Visual Studio 2019 Release

[Note: My development route is UWP first, so some of this may be different for you]

So, I installed the official release of VS2019, and wow I love it!*

Copied my templates folder from my 2017 folder and placed it into the 2019 directory, now… it seems they have changed everything for project selection so using the drop down filters does not work, however, if you just search for MonoGame [Make sure you don’t have VS running when pasting the templates into the templates folder, run it after copying over] it brings everything up, however I found one issue for me, the UWP C# template does not come up, only the VB one……. even after deleting the VB one from the directory [closing and re-opening VS2019] it does not show up, why is the C# one always so different, this was the same when going from VS2015 to VS2017…

Further investigations…

However, for those not familiar or aware, you can install various Visual Studio editions side by side, as such, just keep VS2017 installed for now. [Link and information for VS2017 Installer, down below]

Create your project in VS2017, MAKE SURE YOU RUN/BUILD YOUR PROJECT IN VS2017!, and then just launch VS2019 and open your project using the open option. One thing to note, it might highlight all your code in red underline, if this happens, just either hover over the red underline as you would always do and click the suggested fixes link… I kind of made it irreversible for myself at this point so cannot recall the exact steps, oops lol… might not happen for a fresh project.

If you do not build your project in VS2017, you will have many errors thrown at you and fixing them is as simple as installing VS2017 and Running/Building your project… for now.

One thing you will see in the error window:

Severity	Code	Description	Project	File	Line	Suppression State
Warning	NU1603	Game7 depends on Microsoft.NETCore.UniversalWindowsPlatform (>= 6.2.7) but Microsoft.NETCore.UniversalWindowsPlatform 6.2.7 was not found. An approximate best match of Microsoft.NETCore.UniversalWindowsPlatform 6.2.8 was resolved.	Game7	C:\Users\XXX\source\repos\Game7\Game7\Game7.csproj	1	

I think that can be safely ignored for now until updated official templates are available.

A cool thing I noticed was, the messages list, actually has some useful information in it…

I hope this helps anyone and everyone, whether a complete beginner, or hobbyist or advanced dev.

If you are stuck in finding the VS2017 installer, you should see the VS2017 download on this page a little further down the page [under All Downloads]:

Remember, unless you have subscriptions/licences for Professional or Enterprise editions, download the Community Edition as this is a fully functional and free edition.

  • Side note: ALL CODE COLOURS HAVE CHANGED :frowning:

Remember, I try my best to write my guides here from a complete beginner perspective, so, I assume the user is also very new to coding and may be completely new to some rudimentary aspects such as which Visual Studio editor to use.

Thanks for reading.


Thanks for your post, I have been trying for hours to get it working but your post really helped. I am a Linux/Embedded developer with almost no experience with windows, visual studio and C#. But I have to do a UWP game written in C# for school, and it was really frustrating I couldn’t even get something compiling. I forked the monogame repository in a attempt to implement the installation of the templates for visual studio 2019 but there’s a lot to learn for a newcomer.

Thanks again for sharing the info.

1 Like

Glad it helped, and thank you!

@Joris_Rietveld - have you seen this thread?

I am having the following issues after following your guide here.
It is not recognizing the MonoGame Framework. I have MonoGame 3.8.0_111
I tried 3.7 also and tried making a new MonoGame Windows app from the template, it would not compile, same isssues, and also tried opening one that works in VS2017, it would not compile either, same issues.
I guess I will stick with VS2017 for right now.

1 Like

Looks to me like you have an administrator account issue, but also, did you compile in vs17 then open in vs19? it’s a crucial step.

Nice job resurrecting me from my hiatus :stuck_out_tongue:

I do not test with anything not RTM versions of MonoGame, correction, did not test with anything not RTM of MonoGame, I love how my system corrects MonoGame to Monogamy…

Good luck!

I do not have admin issues, I am the admin on my computer. Yes, I did successfully compile with 2017 then open in 2019 and it still does not work.

Hopefully someone drops by here to assist with that write access issue you got there… I have never had it so, cannot really diagnose in anyway.

Good Luck.

Hi! I’ve just got Windows 10 clean installed and want to installl VS2019 just for monogame android. Im a type of guy that dont want to install anything more than required so my question is:
What is the clean install guide for MG Android with VS2019? What VS components to choose? What android tools to install? Thx

Hi @mpeg88, might do you more help if you started a new request, I am not an Android dev and as such, unable to help you there.

Good Luck!

‘Sigh’ they moved the link for VS 2017 again, just ask if you need help guys.

On another note, just did a clean system install, installed VS17 and VS19, installed MonoGame, built, opened and ran, boom, no issues whatsoever.

I think it might be because the UWP project does not need some things desktop DX does? Wish someone would explore that issue they keep having so we can iron it out.

Well, I was having all kinds of issues after installing Visual Studio 2019 Community back around April 2020. I could not get it to create any kind of project at all. It kept giving me the error, “Can’t access an instance of an object”. I struggled with this for the last 3 months. No posts gave any help with this error. Then, I stumbled upon a post where someone stated that you had to remove an old build framework from the GAC with the gacutil.exe program and make sure you had the latest Windows 10 update. So, I did all of that and then installed the latest build of VS2019 Community and finally got the stupid thing to work. Copied over my Monogame templates from VS2017 and that works now. The only issue I have seen so far is the Content.mgcb file will not open in the pipeline tool even when pipeline tool has been selected as the default. I have to right-click and pick Open With… then select Content pipeline every time I want to use it. At least it works and builds and runs a Monogame project now in VS2019.

I had a similar issue which I could resolve only by using the gacutil.exe. Was really hard to track down since I tried everything before and also the thing the people from Microsoft recommend if nothing else works (which did not help in this case). All I did was to install an update of visual studio and suddenly I could not build anything anymore. Lesson learned I will be more careful messing around with the gac :joy:

Stupid question but did you try repairing VS?

Full uninstall plus special tool from Microsoft to remove “everything” from all visual studio installations from the system.

Did you try a system refresh?

No but I got it solved in the same way as @jnbutler1815 :slight_smile: