MonoGame 3.8 prerelease packages are up on NuGet

I don’t understand any of that…

Please assume I know nothing about anything there…


Got it working now, maybe a cache issue somewhere.

I might – if someone needs it – explain my original method which worked.

Thanks @harry-cpp and @persn for your time and patience with me there, was rather frustrating and really did not need to be…

Time to get stuff running, thanks again :pray:t2:

Link on documentation page for readme is deadlinked


Should it be pointing here:

@harry-cpp Looks like there are some issues with the nuget templates. I created a project via the templates (DirectX) and was not able to add the newtonsoft json nuget to my project (it would look like it’s doing something and then just stop).

When I create a project manually (standard c# .net) and then manually add the monogame nugets, I don’t have this issue (although I have other issues like the font problem per github).

FYI, another issue with the templates is if you create a monogame shared project, you can’t add anything to the project when you right click the project node. Normally you would get an option to add an existing item, new item, new folder etc., But those options are not in the context menu with a monogame shared project.

Looks like we’re almost there, but there are still issues which quite haven’t been ironed out yet.

That’s not an issue with templates… or anything MonoGame related…

That actually is an issue, fixed in #7201

1 Like

Originally I was going to post an issue on the GitHub page, because it appeared that the Pipeline tool was broken in the latest MonoGame Visual Studio development build. But after reading this post and the replies, it looks to me like the latest development build available on is not actually the latest development build. I see references to version in the original post, while is the latest build on the Downloads page. I see mentions in the replies that the Pipeline tool has possibly been replaced by “MGCB Editor,” that NuGet is where to get all of this, and that some manual effort may also be required to make use of the new version(s).

If part or all of this is true, could the Downloads page be updated to reflect this? Is there a place where I can learn about these changes, preferably with instructions? I’m currently using MG with Visual Studio 2015 and 2017, on Windows and Mac. I have never used or installed .NET Core, as far as I know.

Thank you! And thanks for all of your continued efforts to update and improve MonoGame.

1 Like

I’ve successfully upgraded my Window and Android projects to 3.8 and they seem to work fine. When I tried to upgrade the iOS one, it won’t let me install the package, says: “Failed to add reference. The package ‘MonoGame.Framework.iOS’ tried to add a framework reference to ‘System.Drawing.Common.dll’ which was not found in the GAC. This is possibly a bug in the package. Please contact the package owners for assistance.
Reference unavailable.”

e: I fixed this by adding a reference to system.drawing.common manually

Cool, got the MGCB working :ok_hand::+1:


OK OK OK I Like NuGet and GitHub now :sake:

1 Like

I think some of the docs haven’t been updated yet since it’s still prerelease. Until the downloads page is updated, hopefully this information helps. (See the last bullet for one of the docs that has been updated.)

  • “Renamed” might be more accurate. The MGCB Editor is the same as the Pipeline tool.
    • It was renamed to more accurately reflect the association between the MonoGame Content Builder (MGCB), .mgcb files, the MGCB Editor, and the MGCB Task that hooks into your build.
  • The main difference comes in how it’s installed: MGCB Editor is a .NET Core tool (which adds versatility in how and can be used and run cross-platform by the .NET Core runtime).
  • You can find some details on the MGCB Editor documentation page, which outline the “manual effort” required to install the tool. Note that this page links to the .NET Core SDK, which you will need. However if you upgrade to VS 2019, I believe the latest versions come with .NET Core 3.1.

Not wanting to make a mess on GitHub right now, but when trying to clone the repository, I get the following error:

/.git/objects/pack/tmp_pack_XXXXXX’: No such file or directory

I have no issue cloning a private repository.

Please do help and if required I can hit post on my GitHub issue entry.

Starting to understand what is going on somewhat and hopefully it means I can contribute to the project too.


NVM, figured it out, had secure folders on.

I get this issue randomly on creating a new project, anyone know how to fix it?


I thought to try a release build:

Sounds like this is a general UWP issue. A quick search shows different solutions like making sure your assembly name matches your entry point or repairing VS or the Windows SDK.

1 Like

Yeah speaking of the assembly naming, the mainpage/gamepage.xaml always just has UWP game listed.

Giving repair a try.

Wow this is some cool stuff, so mgfx is distributed over nuget?


1 Like

I can’t find MonoGame in Visual Studio 2019 Extension on MacOS. See screenshot below. Anyone else having this issue?

You can use the cli to create new projects.

Will the sound capabilities be upgraded with this release?

1 Like

Not sure what you’re referring to specifically, but there’s no API changes for Song or SoundEffect.

I have a small solution set up with MonoGame 3.7 where I have shared code and shared content in a shared project. Will it work the same with version 3.8?