Monogame Content Builder not working on 64bits

So basically, I wanted to try MonoGame on VS2022 Community.

I followed the Getting Started instructions until when I had to open the Content.mgcb file in VS, I couldn’t open it and I still can’t.

I tried reinstalling MonoGame, installing .NET SDKs for differents versions as I read through several forums where people had problems with MGCB Editor, installing it with the PowerShell console…

Nothing worked, but during one of my tries with PowerShell, I tried to run MGCB (not Editor), and it showed an error because my OS is not 64 bits, which is wrong. I’m on Windows 10 64bits and I have no idea what to do now in order to get MonoGame working correctly…

Does someone have any advice to try and help me ?

Thanks for your tutorial, but it ended up with the same problem…

Upon starting the app just after creating a new project (the UWP XAML), it told me that “The MonoGame content tools only work on a 64bit OS.”, but my OS is Windows 10 64bits, so I son’t know what to do
Sans titre

1 Like

Umm, that’s an unusual one…

I may have found the problem. The MonoGame Content tool may be linked to the 32bits dotnet.exe (located in Program Files x86) instead of the 64bits dotnet.exe (in Program Files).

I don’t really know how to handle it but I’m trying some things. I’ll update this if anything works or if something weird happens.

1 Like

That was indeed the problem, I deleted the 32bits dotnet installation, and everything just went fine, and the mgcb editor now runs normally (at least for now).

1 Like

Mark your solution as the answer, get coding!


Oh and:

Hi @mathieu820, Welcome to the Community!

Happy Coding!

1 Like