MonoGame Extension templates not appearing in "Create Project" menu

I am using Windows and properly followed the Getting Started guide to install VS 2019, select the correct components, install the extension, installed .NET 5, and installed MGCB Editor. However, when I go in to create a new project, the MonoGame templates do now appear, even when searching with both the search bar and manually scrolling through the list.

The extension is installed, and I can even see it in the extensions folder. I installed a different extension which provides templates, and its templates appeared fine with no problems. I have also tried restarting, reinstalling VS 2019, reinstalling the extension, and repairing my VS 2019 installation with the Visual Studio installer.

I have been stuck on this for hours, and just want to start making games, so if anyone can help that would be much appreciated.

I think you are meeting the issue I have solved and am writing a guide for at the moment, what is your setup as I got a strange feeling you are on Mac or something, not Windows…

I will post the guide later tonight or tomorrow.

EDIT

Oh and:

Hi @Milezoefif, Welcome to the Community!

Happy Coding!

Unless Mac OS was redesigned to look exactly like Windows, I’m pretty sure I’m using Windows :). It’s Windows 10 with AMD CPU and GPU, if that matters.

I’ll be sure to watch out for your guide though, for sure. I looked for solutions to my problem, but the closest I got where outdated solutions from MonoGame pre-3.8. Its a shame MonoGame isn’t the most popular, meaning tutorials and advice are sometimes scarce.

Many Thanks

1 Like

Posted the fix just now.

Fixing the templates issue in 3.8 Nuget - General - Community | MonoGame

I installed the Windows 10 SDK 10.0.18362.0, but the templates still won’t appear. I restarted my computer and reinstalled the MonoGame extension. The icons aren’t even missing, the templates literally do not appear in the menu, and its the only extension that does this. Weirdest part is that the templates are installed, but VS doesn’t want to show them apparently?

Is there some other way I can properly install the 3.8 templates?

Many Thanks

What are you selecting in the loadup?

Notice the three drop down menus at the top, I made this mistake when the update happened as it used to be in UWP but now it is in MonoGame

Interestingly, MonoGame isn’t even an option in the drop down

And even searching through the entirety of the “All Project Types” doesn’t show anything. The “Games” option doesn’t give any results either.

Which guide did you follow for MG and which edition?

EDIT

Follow my Day 1 guide for a from scratch project for UWP, or DesktopDX… see where you run into issues…

I’ve been following the guide on the Monogame.net website, and for 3.8. Also quick question that may or may not expose me as an idiot: Am I supposed to download/install these things as well?

If so, uhh… whoops.

What guide are you following? I have never gone to that screen before…

EDIT

I wrote an in-depth guide somewhere… hang on EDIT NVM, I made videos and removed them…

EDIT

Are you using this one?

https://docs.monogame.net/articles/getting_started/1_setting_up_your_development_environment_windows.html#install-mgcb-editor

Yeah, thats the guide I used.

The page is the downloads(?) page, and I found it from the Monogame.net website:

Clicked “Get Started”

Clicked on the latest stable release

Then got sent to this post, whereupon clicking on “MonoGame 3.8 Assemblies and Tools” I got sent to this page:

Did you even try clicking my link?

EDIT

Notice the Getting Started Link in Tom’s post

Just do this and the MGCB editor part

Yes, I did click the links (Both yours and Tom’s), the “Setting up your development environment for Windows” guide is the one I had used to get everything setup.

I have the Monogame extension and MGCB editor both installed:

Reinstall it, and if that fails [I did have issues with a cache issue at one time, you can also hunt down the NuGet folder and delete the cache there]

Alternatively, repair VS as a last resort.