🔧 Fixing the templates issue in 3.8 NuGet

Fixing the templates issue in 3.8Nuget

This is a repost of a thread post for easier discovery.
Originally posted in my guide’s thread:

So, I accidently stumbled across a fix for this issue the other day. I will try to keep this one short, no promises.

Modify your VS setup and ensure you have the following selected:

Windows 10 SDK 10.0.18362.0

Around 720MB when I downloaded it.

image

You might still see your list looking like this:

How I came across this fix:

When I chose a UWP XAML template, I noticed the template failed to load and it unloaded the project, but that got me wondering, did it create the files?

It does! Right click the project that shows as unloaded in solution explorer on the right, and choose to Open Folder in File Explorer, enter the folder there, and then open the CSPROJ file, viola, your project is there, if you look to the right in solution explorer again, you should see a yellow box with INSTALL a missing component mentioned, click the install for a specific fix for your build.

However, once the SDK is installed, this issue is no longer a problem.

Happy Coding!

2 Likes

My templates are like this too. I can still use them seemingly fine, but they lack the “UWP”, “Xbox”, etc tags (as screenshotted above), which is mildly sucky.

1 Like

I already have the same problem, can you explane it better?

Which part?

How can I find the folder ??

Can’t be clearer, unable to post a screenshot as it is already fixed on my main system for now.

Screenshot (3)

wich of these ?

Have you tried, building yet?

i tried now but he dont run and say that netcoreapp3.1\Project1.exe does not exsist

That’s an unrelated issue, please post a new thread so someone can help you with that.

1 Like

i did it here Error Monogame Templates on VS 2019 ; can you help me ?

Please don’t span the forums like this.

I cannot help you as you do not provide any information.