[SOLVED] iOS project template - broken?

Hi all:

I’m wondering if anyone else has had trouble with the “MonoGame iPhone/iPad application” template. Here’s what I did:

  1. Installed MG on my Mac
  2. Booted up Xamarin Studio
  3. Selected “new project”, pressed OK
  4. Selected “MonoGame iPhone/iPad application” template, pressed OK
  5. Run (command-R)

It says 0 errors but it never runs. Tried all iOS targets: no go

Is this happening to anyone else? I have experience w/ MG and w/ iOS development, but this is behavior I’ve not seen before.

This old thread mentions the same thing…

That was 3.5 years ago: it’s the same issue, but I would think it’s been resolved by now. Or…?

Any help would be much appreciated!


What MonoGame version and what XS version?

Xamarin Studio 6.0 (build 4761)
MonoGame AddIn

I’ve always upgraded XS using its internal upgrade mechanism, but that hasn’t been working, so now I’m upgrading to 6.1.1 via the web.

OK, it works now. I had to download & install XS Community.

@Jjagg - thanks for asking the question about version numbers! I believed I was up to date because XS always self-upgraded until now. I suppose the Microsoft buyout changed everything.

1 Like