[Solved] Monogame 3.5 - 30FPS When Not Using FixedTimeStep.

Hi everyone, I’m having an issue wherein, regardless of what I update/draw/etc (I even commented out all of the draw/update code except the framerate counter, which prints once every 100 updates), the framerate sticks to 30FPS when I have IsFixedTimeStep set to false.

To name a few troubleshooting things I’ve tried: I have tried setting vsync to false, commenting out all of my draw code, using only one texture (have a texture atlas that goes through the MonoGame content pipeline; 256x256px).

Does anyone have any immediate idea as to what may be happening? I plan to still keep trying to debug my application in the meantime; I couldn’t find anything online as to what the problem may be.

Thank you for your help!

Really sorry, but this was a stupid issue. Laptop was throttling because apparently my charger fell out of the wall while I was coding; secured it to a different [more stable] outlet and everything’s working fine.

My apologies again; that was really stupid of me, haha.