[SOLVED] Recent NVIDIA Update broke WIN-OPENGL version ?

After the aforementioned update my Opengl monogame version crashes
“GL.BindFramebuffer(GLFramebuffer, this.glFramebuffer);”

‘System.EntryPointNotFoundException’ occurred in OpenTK.dll
Unable to find an entry point named ‘glBindFramebuffer’ in DLL ‘opengl32.dll’.

Any hint?

Rolling back the update did the trick and fixed the issue… i wonder what the cause could be… an incompatible opengl version?

What driver version is the working one, and do you remember the driver version that broke?

The “broken” one would be this :
NVIDIA - Display - 12/29/2016 12:00:00 AM -

The working rollback one would be

I can confirm this issue is happening on a different pc with nvidia drivers… i’m unsure if this will affect opengl games released …

Got the same issue, the graphics context is set to GDI Generic Device with Open GL 1.1.0 instead of the one that is supported by my graphics card. (4.5 I believe for GeForce 1060)

Is there any way to control which graphics context is being used by the game? The OpenGL Extension Viewer is reporting multiple possible contexts for me, but the first on the list is GDI Generic Device, which I think is also picked by the MonoGame/OpenTK as default.


I had been on the (NVidia’s 376.53 drivers, notice the last five digits of both version numbers match) that whole time since it was released at the end of 2016. I’m on Intel i7 (with on-chip Intel HD 4600, but it’s not connected or used) and a NVidia GTX 560. I just updated to the latest (NVidia’s 378.66 drivers) and still don’t anything strange. As stated in this other thread, latest MonoGame no longer uses OpenTK on DesktopGL. Have you tried the development build from monogame.net? We should also have a 3.6 release out in the next week.

I’ve added the NuGet feed to my Visual Studio and got the develop version of MonoGame ( Now it is complaining about missing SDL2.dll file - should I add a reference to SDL too?
I tried downloading latest SDL2 from their website and received “BadImageFormat” exception (which is basically a .dll version mismatch from what I know).

What are the required references for the MonoGame develop?

Upgrading my project to latest MonoGame 3.6 runtime solved the issue.

Here is how I did it, since I had trouble with just replacing the referenced libraries and using my old .xnb resource files.

  • get latest installer for Visual Studio
  • create new “cross platform desktop” project from MonoGame templates
  • add all my .cs files, add all content files to the Pipeline tool config file
  • fix an issue with LoadContent() function being called each time graphics.ApplyChanges() is called
  • run the project
    = SUCCESS!

Could not update the reference through NuGet package manager, because I was still missing the SDL2.dll. Once I got this, it started complaining about soft_oal.dll. Once I got this, it started complaining about yet another dll… Never ending story - figured out that the template should have all the proper DLL files in it and that it will be easier to setup a project from scratch. It worked. :slight_smile: