Texture is transparent but shouldn't be

All my Textures are a bit opaque, as you can see in the following picture:
Anmerkung 2020-05-29 161858

First I drew the rectangles (I generated the texture within my code), then I drew the ship ontop of my stars. But the Ship is now a bit opaque.
I hope you can help me with my problem. I can also provide some of my code, if its necessary.

Which BlendState mode do you use in SpriteBatch? BlendState.Additive used to do this, or similar. Try this:


or BlendState.NonPremultiplied, which brings better results.

Your solution doesn’t change anything. I tried both options but neither of them seem to work.

But I’ve been doing some experimenting and it turns out, that the objects are transparent because I draw them in different classes and I’m calling multiple times spriteBatch.Begin();. Maybe that induces my problem? Can you help me fix this issue? I would prefer drawing in different classes.

Okay, I now rewrote my game and implemented a IDrawable interface and a IUpdatable Interface. Its now working fine.

I don’t know how, but this thread is now CLOSED.