Unable to load 'freetype6'


I know that there are quite a few posts on this problem, but i still haven’t found a working solution. I am attempting to build a simple spritefont in the MGCB, but i am getting this error:

I have installed the 2012, 2013 and most up to date C++ redistributable SDK’s and I have reinstalled freetype6, both to no avail.

I’m using Windows 11 and VS 2022

Thanks for the help

Edit: It might be worth mentioning that I couldn’t build png images, due to the ‘FreeImage’ dll error, but i fixed this with the 2013 c++ redist. Is there a problem with MGCB on VS2022?

I’m not using MGCB, but the freetype6.dll I use for fonts requires VS2010 runtime.

The best way to know what you need is downloading a dependency walker (like https://github.com/lucasg/Dependencies ) and opening the DLL with it. It should tell you what DLLs require (in my case it requires MSVCR100.dll, which is VS2010 runtime )

Hmm, I’m not really experienced enough to know what to do with all the information. One dll said it wasn’t installed, after I installed that and rebooted the problem persists.

It’s easy. Run the dependencies program and then open the DLL which gives you the problem. On the top left will appear the dependencies, marked with red (as seen in the screenshot) the DLLs that the program can’t find. That’s usually the offending DLL.

Afterwards you have to discover which package you have to installl to get that dependency solved. In this cas, it’s MSVCR100.dll belongs to VS2010 runtime.
(never never ever download and copy a DLL from one of those “dll is missing” web sites, because that DLL can have other dependencies and nobody assures you that dll won’t be infected.)


Does this mean they’re all installed correctly?

yes, it finds all DLLs. Does it still fails?

Unfortunately it still does not work

no idea so far :frowning:

However it is weird that freetype6.dll is located in c:\windows\syswow64 , monogame installers should never write there. The DLL to check should be in the same folder as the content builder is located ( mgcb.exe , IIRC)

I have fixed it! I was checking the wrong freetype6.dll, The one in the MGCB folder did not have all dependencies, downloading the 2010 C++ redist worked, Thanks @KakCAT

1 Like