Using Monogame with Tiled and Monogame.Extended

Hello everyone, I’m hoping to get some help here.

I’m making a 2D game using Visual Studio 2017 and Monogame. I tried to use tIDE to make my 2D map but found it wouldn’t work and was redirected to using Tiled with Monogame.Extended.

I’ve made my map but I’m having a few problems while following the tutorials:

1: Bunch of errors in the error list as it tries to debug the .tsx file. [cannot find name ‘xml’.] [cannot find name ‘version’.] [cannot find name ‘encoding’.] [Couldn’t find a default importer for “path”.] and the Content command exited with code 2.

  1. additionally, following a tutorial I found, and I notice that my map file didn’t save it’s columns or tilecount in the xml file, there are no attributes with that name.

  2. Lastly, in tiled I notice all of the options for creating shapes are greyed out with no explanation.

Really hoping I can get some help! Thanks :smiley:

Edit: So I realized that I only installed the nuget for Monogame.Extended, didn’t realize I was also supposed to install the nuget for the Content.Pipeline. I’ve installed that and added the Content.Pipeline.dll as a reference in the project. It doesn’t seem to have made any changes in my errors :confused:

Second Edit: Tried removing and readding the files to the Content.mgcb directly and that seems to have dropped the errors down to Couldn’t find a default importer for Mp1.tmx