VS2019+MonoGame Issue. HELP please.

Hello everyone! thanks for accepting me in the group. I hope this on-topic because a need some help with it.

It is my first year learning programming at college and we are using monogame to develop a Space Invaders game. I installed and reinstalled VS2019 and Monogame several times, followed all the steps and it does not work. When I open a new project It displays differently from my colleagues and my lecturer. The logo is missing and replaced by a strange black square thing with a “humanoid figure”. Also when I get in the program itself it does not display the logo on the Content.mgcb and when I try to add a PNG. image for the Sprite to the content folder it does not work because is missing the .xnb file. I already tried to use a PNG to .XNB converter and it does not work unless I go manually to the content folder and paste the xnb file there. After “fix” that the next problem is to add the fonts, as I am not able to add them troughtout the content pipeline I can not continue with it. I am highly frustrated and my lecturer does not know what is wrong with it. If any of you could help me I would really appreciate it. Thank you. (I add some screenshots so you can see it).

P.S.: I have two users in my laptop, both are Admins, if that is any help.

1 Like

Hello @Manuel_Guerra! I can’t guarantee this will work, but have you installed the MGCB Editor
and (before that) the MGCB Pipeline? Then set the MGCB Editor as an option for the default to open .mgcb files by running the command mgcb-editor --register.
After that, right-click the .mgcb file, go to Open With > mgcb-editor-wpf > Set As Default > OK.
Hopefully this helps. If you need any screenshots, let me know! :slightly_smiling_face:

ALSO! Make sure to add your content to the project using the MGCB Editor. That way it will build to the content file and you will hopefully get your .xnb binaries. I also have the weird humanoid figure for my MonoGame templates but they work just fine.

I have solved this issue, I will be posting a guide later today… maybe.


OH also…

Hi @Manuel_Guerra, Welcome to the Community!

Happy Coding!

1 Like

Posted the fix.

Fixing the templates issue in 3.8 Nuget - General - Community | MonoGame

1 Like