App packaging for Mac, The application "YourGame" can't be opened.

Hello, so I’ve followed the steps for .app packaging listed here… Package games for distribution | MonoGame Documentation

And no matter what I try the app package simply will not open.

I’ve built an empty OpenGL cross-platform project on windows, as well as mac, titled it “YourGame”, copied the plist file. Setup the folders as stated… and can’t seem to get it to work.

I’m on MacOS Catalina 10.15.3
2.26 GHz Intel Core 2 Duo
8 GB 1067 MHz DDR3
NVIDIA GeForce 9400 256 MB

I can create and run an empty project on my Mac. I can run the osx build built through windows through the terminal with ‘dotnet YourGame.dll’

I’ve even tried the FNA listed route here with mono kickstart, 3: Distributing FNA Games · FNA-XNA/FNA Wiki · GitHub

But all with the same result and no idea what I’m doing wrong.

The only other option I’ve found that I haven’t tried yet is mkbundle, Creating self-contained applications with MKBundle | Mono

And of course right after I make a post here I solved my problem. If anyone else runs into this I was clued into the solution by this post here, After using "dotnet publish" game crashes on Mac only

The issue was the extensionless file, “YourGame”. On mac with the app packaged in the .app folder format, I navigated to the MacOS folder with all the game files through the terminal.

Run sudo chmod +x YourGame

I zipped the app, transferred it to google drive, redownloaded it and it now works like a charm.

1 Like

Hi, I have a similar issue, I have tried the sudo chmod +x command. Mine says yourgame.app is a directory when I open in terminal…