Visual Studio 2017 New Windows 10 Universal Project Error

I’ve installed Visual Studio 2017 Community Edition, and then installed MonoGame 3.6.
I open Visual Studio, go to New > Project
Select ‘MonoGame Windows 10 Universal Project’

I get the following error:

Error: this template attempted to load component assembly ‘Microsoft.VisualStudio.WinRT.TemplateWizards, version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a’. For more information on this problem and how to enable this template, please see documentation on Customizing Project Templates.

I’ve tried past posted on correcting a similar issue in past Visual Studio 2015 templates, but no avail.

Any help would be greatly appreciated. Thanks!


Cory Kroll

Unfortunately this bug made it into the 3.6 release. It is fixed in the develop branch by this PR
You can get the develop version to resolve the issue (on the Downloads page under Development Builds). There’ll be a 3.6.1 release that will contain the fix, not sure when though.

If it does not work. You can edit the file:

In the directory: C:\Users<username>\Documents\Visual Studio 2017\Templates\ProjectTemplates\Visual C#

And run the following command: devenv /installvstemplates

1 Like

I downloaded the latest develop version (MonoGameSetup.exe, Fie version
After installing and reopening Visual Studio 2017, it didn’t fix it.
I’ll try the other options in this thread - any other suggestions?

Thank you! This solution worked like a charm.

I’m really curious - what does the command devenv /installvstemplates actually do?

I thought at one point Visual Studio read directly from my MonoGame templates folder. Does this command copy these templates somewhere? Put them in some hidden folder or something?

yeah! I do not know exactly. But if you do not run the command: devenv /installvstemplates.It will not work.

For Visual Studio 2015. You will not need to run that command

I have performed the steps listed above, I can create a the project, but i’m unable to deploy to the Xbox One, I just get the following error.

Any ideas, why this is happening and how to resolve?

I’ve tried googling the error code but i’ve not found any solutions of how to resolve.

I’m using latest develop version (MonoGameSetup.exe, version

I just tried deploying to XBox One and had success. XBox One was in the Dev Home when I deployed. I deployed the barebones project (light blue screen). I didn’t get the same issue.
In the known issues document on MSDN it does say deployment issues can occur if parental controls are on - so if they are, be sure to turn them off. Can you compile and run the app locally?

I deployed it in the same way, an unmodified project blue screen app, build compiled and run on windows, app compiles but just won’t deploy to Xbox.

Just like you, Xbox was in the Dev Home, just in case I un-paired the device and re-paired, still no joy. Checked parental controls, they are not enabled.

Hmm ok. Other random ideas:

  • Make sure you are not running the beta software at the same time, or haven’t recently switched from the beta program to the dev program (I’ve heard they don’t play together well)
  • Got any firewall, anti-virus, or port blockers running? Turn 'em all off
  • Have you checked for updates on XBox One in a while? Maybe there is something new to get
  • Try pairing Visual Studio to your XBox again. Maybe that’ll do something?
  • What Windows 10 version did you target when you created the template? I chose the Anniversary update. Maybe this makes a difference?

Good luck to ya! If this doesn’t work you might want to ask this question in a new thread, along with what you’ve tried already. Asking this under my new project template question may not get you a good audience for help.


Given me some things to try, I’ll start a new thread just in case someone else is having the same issue, and list what I’ve tried, hopefully I can find a solution.

Link is dead :frowning:

Try my suggestion above for now

I am using the development branch, and installed both VS2015 and VS2017. Still dont work.
Can someone upload an empty Win10 project - and I can try using that.

EDIT: Solved it by reinstalling both VS2015 VS2017 and Monogame development branch

Are you using 3.7? blah blah blah extra words