MonoGame 3.8 MonoGame.Content.Builder.Task breaks my project..

Hi all, I know I have probably done something daft and missed an installation step, but I have just created a project to test the engine I am writing, and when the template is loaded up, I get a load of odd error messages…

From the off, is shows tha it has not been able to find the MonoGame packages:-

I also get this in my error list window

If I remove the MonoGame.Content.Builder.Taks package, and build it all get’s fixed…

Adding it back in breaks it again…

Anyone know what I am doing wrong here?? Or what I may have missed off in the installation proecss of 3.8? I just went and checked the MonoGame pipeline tool, and discovered it’s still using 3.6, could that be the problem, though I did follow the instructios to install the 3.8 tool too…

Trying to re install the 3.8 MGCG gives me this:


Your usename has space in it. : )

1 Like


Really, that’s the issue?? lol

So, I need to change my username on this machine?


Also fun detail – changing your username on Windows leaves User folder with the old name anyway.

But my user name is tied to my MS account, so…

Imo, logging into Windows with MS account is the last thing you wanna do.

You can also make a hotfix nuget. It’s probably somethinng easy like enclosing paths into quotes.

Erm, no, it’s not lol

Ill have to wait for a fix on this, I can’t be messing about with my user account… I can work around it for now…

1 Like

Thanks for the info though :slight_smile:

The $(MGCBPath) property is the only parameter which is not quoted in the command. You can also see that in your error message.

So quoting this property will likely fixing this bug.


Sweet, thanks, ill give that a try :slight_smile:

Awesome, that actually worked, shame Ill have to do that each time I add this package :frowning:

This was actually recently fixed in master. Try the dev packages :smiley:
I wonder if that $(DotnetCommand) should be quoted too…

1 Like

Possibly, but until it’s an issue, ill leave it :smiley:
Thanks for the heads up on the fix :slight_smile:

I’m getting the same issue, did you find how to solve it?

Yes @BlizzCrafter post worked :slight_smile:

@Charles_Humphrey I’m new to this and I don’t know what exactly I have to do with that, can you tell me?

Yea, no worries, let me get on my laptop and I can screen shot what I did :slight_smile:

So, I opened up my solution, and located the offending package.

I then copied that into explorer

Then, in the build folder I found the *.target file, I opened that up in VS and put quotes around the $(MGCBPath) like this

saved the file, and it solved the issue.

Alas, every time yo create a new project, you will have to repeat this again.

Hope this helps :smiley: