[SOLVED] ContentLoadException in version

What causes this kind of exception? I copied a solution from one machine to another but it works only on one of them. I guess there is something messed up with my MonoGame installation on the machine where I get this exception:

Microsoft.Xna.Framework.Content.ContentLoadException occurred
  Message=Could not find ContentTypeReader Type. Please ensure the name of the Assembly that contains the Type matches the assembly in the full type name: Microsoft.Xna.Framework.Content.ReflectiveReader`1[[Microsoft.Xna.Framework.Content.Pipeline.Graphics.MaterialContent, MonoGame.Framework.Content.Pipeline, Version=, Culture=neutral, PublicKeyToken=null]] (Microsoft.Xna.Framework.Content.ReflectiveReader`1[[Microsoft.Xna.Framework.Content.Pipeline.Graphics.MaterialContent, MonoGame.Framework.Content.Pipeline]])
   at Microsoft.Xna.Framework.Content.ContentTypeReaderManager.LoadAssetReaders(ContentReader reader)
   at Microsoft.Xna.Framework.Content.ContentReader.InitializeTypeReaders()
   at Microsoft.Xna.Framework.Content.ContentReader.ReadAsset[T]()
   at Microsoft.Xna.Framework.Content.ContentManager.ReadAsset[T](String assetName, Action`1 recordDisposableObject)
   at Microsoft.Xna.Framework.Content.ContentManager.Load[T](String assetName)

Found out I get this error also in other projects now. I think this has to do with the Installation of the latest development build. Is there anything related to content that needs to be changed inside the visual studio solution, so that everything works with the latest development version of MonoGame?

Which version of Monogame is installed on those machines?
Did those projects worked with a previous version?

Sorry I should have provided this information already…

Previously installed was version: using the link in the download section for the official public release (http://www.monogame.net/2017/03/01/monogame-3-6/)

I installed version: using the link in the download section for the latest development build (http://teamcity.monogame.net/repository/download/MonoGame_PackagingWindows/latest.lastSuccessful/MonoGameSetup.exe?guest=1)

Yes, the projects did work before.

I just tested it again, it is working with version

With version

Can you try something?

Download SharpDX 4.0.1 and copy the Mathematics dll into the monoGame installation.

C:\Program Files (x86)\MSBuild\MonoGame\v3.0\Tools

C:\Program Files (x86)\MonoGame\v3.0\Assemblies\Windows

Also try an older Develop version.
The material imported had some changes recently.

Sure, where can I download SharpDX 4.0.1? I tried downloading the nuget package and cloned the repo (tag v4.0.1) but I could not find a Mathematics.dll?

Try this one. https://www.nuget.org/packages/SharpDX.Mathematics/
Note that this is just a suspicion I have, It might not work.

How about, did it work?

I copied the mathematics.dll to both directories and tried, but it did not work.

Took me a moment to figure out I can download the file by clicking log in as guest on the team city login page …

I will try with this version and report in a moment.

1 Like

No success with

the plot thickens…

I have no idea what’s happening.

Thanks for your help. Maybe I could try some other development versions, to find out where or when the break happened?
Can I access the other team city installations somehow?

It keeps only a couple of old versions and you need to find your way around. Look at the Artifacts in the link I gave above.

You can also get them from the nuget feed. The link is in the download page.

Can you try something else?
In the pipeline switch from “Open Asset Import Library” to “Fbx Importer”.


That did it!

So for *.obj files the FBX importer should be used?


Hopefully this will get fixed. Until then… whatever works.

1 Like

FYI… working on a fix https://github.com/MonoGame/MonoGame/issues/6179

1 Like

Note, I’m using the now current pipeline that came with the now current dev build, and this is still not fixed.
I have to use the dev build because 3.7.1 still did not fix the OpenAL bug.
That or go back to 3.6.

Use the fbx importer instead, that’ll work (even for non-fbx files).

Mate, I am kinda new to Monogame and I have the exact same issue!

Where exactly can I make your suggested change happen?

Thx in advance!

Open the mgcb file in the mgcb-editor and select the content, then on the left you can change which importer will be used for the selected asset / model.